Endless update/restart cycle


#1

Using Brave on OS X 10.10.5. I am continually caught in a cycle of:

1 I launch Brave and start using it
2 I get notification of available update (“Hello! A Brave Update was just released. requires a quick relaunch…”)
3 I click Update button
4 Brave closes, and after a few seconds restarts
5 I continue to use Brave, but if I check version it is the same as before
6 After a few minutes I have the same notification as in (2) above…
7 I click Update button - see (3) above
…and it goes on repeating this cycle.

This cycle goes on endlessly. Also, available disk space starts to go down and I look in
/private/var/folders/xx/…/
and I see numerous copies of the Brave.app - currently 7 copies so 2.8GB. So somehow it’s downloading the update but not installing it.

The only way round this is to delete the app, trash the ~/Library/Application Support/brave folder and the above mentioned folders and reinstall the new version. but then the cycle starts again at the next update…

A real shame because I very much like this browser, but I can’t put up with this!


Updates not being applied on browser restart MacOS Sierra
#2

This is a really unique bug! After trashing the /brave folder did you restore any of the files or did you start from scratch?

What ancillary protection systems are you using (antivirus, app firewall, etc)?

Is this a multi-user machine?
Also, what are the specs for your machine? MacBook Pro/Air/Hackintosh?

Thanks!


#3

Thanks for the reply, Alex. Answers to your queries:

After trashing all the Brave-related folders, I emptied the Trash before reinstalling. So, no traces of the old install, I reconfigure my preferences every time.

No anti-virus, just the OS X firewall and also Little Snitch, but that doesn’t have any rules set for Brave (mainly because it seems to behave itself!)

This happens on two machines, a mid-2012 MBA (i5, 1.8GHz) and a late 2012 Mac Mini (quad i7 2.3GHz). Both machines have multiple users set up, but at least on the Mini I know that no-one else logged in whilst all the Brave update/restart thing was going on. I don’t think other users interfered. But talking of users, FWIW for security reasons I always run as a non-Admin account for my day-to-day work. If any updates/installs are needed I then enter the Administrator name and password.

Also FWIW this started on Brave 12.x (whichever the last 12 version was, I can’t remember), then 13.0, 13.1 and now 13.2.

Hope all that helps!


#4

EDIT: Interestingly, I’ve just noticed exactly the same behaviour happening for the Atom editor. It is endlessly downloading 1.14.1, I attempt to install and relaunch, it then relaunches but still on 1.13.1, and multiple copies of the 1.14.1 package are in private/var/…/

Atom / Github also seem use ShipIt to deploy the updates, as do Brave / Electron.

Don’t know if that helps?


#5

Thanks for the bug report. Could you possibly try running Brave on the Administrator account and attempt to apply the update? That will tell us if it is a permissions issues.

Thanks


#6

Sure, I’ll see if I can find a copy of 13.1 on my backups.


#7

OK, I realised I still have Brave 0.13.1 on one machine, so I logged in as the Administrator on that. Firstly I deleted all of the Brave-related entries in private/var/folders/…/ so that there were no part-downloads around.

There follows an informal log:

  1. Launch Brave
  2. Browse a bit
  3. Popup appears, see screenshot A
  4. Click Add Helper
  5. See usual "A Brave Update was just released message in browser, see screenshot B
  6. Click “Update” button
  7. Brave closes
  8. Wait… (I gave up after 10 minutes)
  9. Launch Brave again and check version, it is still 13.1 so hasn’t updated
  10. Browse a bit
  11. See (3), same popup appears
  12. Click Add Helper
  13. See (5), Brave update was just released…
  14. Click “Update” button
  15. Brave closes
  16. Wait… (I gave up after 10 minutes again)
  17. …and repeat
    After this I checked /private/var/folders/…/ again and there were 6 new subfolders, see screenshot C.

So, no further forward but I did get an extra dialog box!

Hope this helps.

…"


#8

Hi, just wondering if there’s any update to this? I have since progressed to OS X 10.11.6 and Brave 14.x and still having the same issue.


#9

Same thing happens to me. Everytime I open Brave on latest MAC OSX, it asks me to enter my password to install some “Helper”. Not very good user experience.


#10

Same thing that @FourSticks wrote about ~3 months ago has been happening to me for last several Brave versions (currently running 0.15.0).

I’m on Macbook Pro 2016 with Touchbar. OS Sierra 10.12.4

I have 2 user accounts (Admin account and regular user account). I am installing through my regular user account. I have to completely uninstall Brave (including deleting the Brave files in private/var/folders and Library/Application Support) and then reinstall it from scratch. Very annoying to have to do this every time.

Please fix…


#11

Yes, still happening for me. I’ve just upgraded to Brave 15.0 by the same tedious method: deleting the app, ~Library/Application Support and /private/var/folders and installing the new one.

I think I’ll give it one more try and see how the next update goes, and then ditch Brave. Shame, because it has a lot of potential.


#12

Within the last week, downloaded Brave for the first time. Within several days, I have the same problems as mentioned above. OS 10.11.6 mid 2013 MacBook. I too will remove and reload one more time but if still getting update messages, something is not right and not worth trying to figure it out. Your browser is a good idea and potentially good upside, but maybe it needs some more beta work before releasing…


#13

Yep, still happening here too. Just deleted 24 copies of the latest (15.1) update of the app that it had downloaded itself and not installed.

So, I’m out of here. A real shame but it doesn’t seem that this is being attended to and also it doesn’t seem that this thread is monitored any more. Kudos to anyone developing free software though, I certainly couldn’t do it. Maybe we’ll see a working version in the future, hopefully so.


#14

hey @alex is this 3 month old issue going to be fixed / what’s the ETA? I’m about to permanently uninstall as well (like FourSticks and @microbarny) b/c no one has time to uninstall Brave…delete all the hidden folders and installations…then reinstall Brave again…and re-do this EVERY time there’s an update…


#15

@braveuser1 thanks for flagging me on this.

Some of the conversation has moved to https://github.com/brave/browser-laptop/issues/2184 and seems as though it may be pretty deep in one of the dependencies https://github.com/electron/electron/issues/6345

As far as I can tell there is no easy answer for a code-based solution yet. I’m going to nudge the engineering team for another pass though.

In the meantime, we do have this in our FAQ :

I think you should only have to fiddle with that once.


#16

I also have noticed this phenomena, however, I simply go to the Brave website, download Brave, open this dmg, in this process I get the window with one of the options asking if I wish to replace the current brave app, I select to replace. Then when you open the brave app it is the latest version. I don’t bother uninstalling anything, simply install the latest version from the website, install the new version over the old by selecting the replace option. The new version opens without any further fiddling. Yes it would be nice to be able to use the update version option provided by Brave, but it simply is not being fixed for macOS and hasn’t been for some time.


#17

I have the same problem since today: update! add helper, pass word, and then again and again … I run a Mac 10.9.5 … happened again while I am typing this post … don’t know what to do!


#18

@bleriot have you tried https://github.com/brave/browser-laptop/wiki/End-User-FAQ#updates-are-available-but-applying-them-doesnt-work-on-macos ?


#19

@alex, I tried those steps including the full restart, as both my admin user, and non-admin.

I removed this dir for both users ~/Library/Application\ Support/com.electron.brave.ShipIt/.

Here are my logs after clicking the “update” button:

2017-07-21T13:41:02.681Z - updateUrl = https://brave-laptop-updates.global.ssl.fastly.net/1/releases/dev/0.17.16/osx
2017-07-21T13:41:13.009Z - checkForUpdates
2017-07-21T13:41:13.161Z - lastCheckWOY = 195
2017-07-21T13:41:13.107Z - lastCheckYMD = 2017-07-21
2017-07-21T13:41:13.218Z - lastCheckMonth = 7
2017-07-21T13:41:13.262Z - firstCheckMade = true
2017-07-21T13:41:13.262Z - https://brave-laptop-updates.global.ssl.fastly.net/1/releases/dev/0.17.16/osx?daily=false&weekly=false&monthly=false&first=false&accept_preview=false
2017-07-21T13:41:13.456Z - Metadata: {"version":"0.17.19","name":"Brave 0.17.19","pub_date":"2017-07-19T18:04:38.555Z","notes":"Numerous performance improvements, fixed tab display when closing tabs, fixed history listings and fixed a security issue for WebTorrent. More details: https://github.com/brave/browser-laptop/releases/tag/v0.17.19dev","preview":false,"url":"https://brave-download.global.ssl.fastly.net/multi-channel/releases/dev/0.17.19/osx/Brave-0.17.19.zip"}
2017-07-21T13:41:13.733Z - update downloading
2017-07-21T13:41:48.486Z - update downloaded
2017-07-21T13:41:48.486Z - Release notes : Numerous performance improvements, fixed tab display when closing tabs, fixed history listings and fixed a security issue for WebTorrent. More details: https://github.com/brave/browser-laptop/releases/tag/v0.17.19dev
2017-07-21T13:41:48.487Z - Release date: Brave 0.17.19
2017-07-21T13:41:48.487Z - Update URL: Wed Dec 31 1969 19:00:00 GMT-0500 (EST)
2017-07-21T13:43:04.637Z - platformBaseUrl = https://brave-laptop-updates.global.ssl.fastly.net/1/releases/dev/0.17.16/osx
2017-07-21T13:43:04.637Z - updateUrl = https://brave-laptop-updates.global.ssl.fastly.net/1/releases/dev/0.17.16/osx

After this process, there is still nothing in the com.electron.brave.ShipIt folder (for either user).
Brave is still on 0.7.16.

I wouldn’t even really mind just downloading and replacing the browser in /Applications, but it seems to reset some of settings.


#20

Replacing the app in /Applications shouldn’t change any settings, but removing ~/Library/Application\ Support/brave will for sure. :slight_smile:

This is quite vexing for a handful of our OS X users (and for me since I can’t reproduce it easily).

Would you mind doing a long listing (ls -l) for the following :

/Applications/Brave.app
~/Library/Application\ Support/brave
~/Library/Application\ Support/com.electron.brave.ShipIt/

Also, if you could show your remaining disk free space :
sudo df -h /

I would like to make sure it’s not an ownership or space issue.

Your assistance would be super helpful toward this effort.

Thanks!