Enabling Push Notifications

Hi there, I am new to Brave, though fairly brower savvy in general. I am trying to enable desktop push notifications through Brave.

  1. To that end, for the sites I am interested receiving them from, I have (at least temporarily) gone ‘shields down’ on those sites so that I can see/access the option to subscribe (often, but not always, a bell avatar widget).

  2. I have gone into site settings in Brave and ‘Allow’-ed notifications from those sites.

Push Notifications

  1. But something is blocking the final step, successful push subscription/completion, as subscriptions aren’t being confirmed (usually with a first push popping up) and further to the point, when one is successfully subscribed through a push service, the avatar/widget either goes away or changes to a ‘unsubscribe’ option. That isn’t happening, it appears as if I haven’t tried to subscribe at all. In addition, I know both sites have sent out push notices since I tried to subscribe on dektop, as I received them through the Brave app on Android.

There seems to be one last setting in Brave desktop that is preventing the push subscription from completing and I cannot figure out what that setting would be.

If anyone can help me identify/resolve the problem, that would be much appreciated. I’m transitioning over from Comodo Dragon after their most recent update borked the search engine features, which is a deal breaker for me. So far, everything on Brave is setting up just fine but for the push notices. I hope this can be solved! Thank you in advance.

Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (64-bit)

1 Like

< irrelevant info > Sorry, mixed-up posts. :flushed:

Hello @Calista

what you mean with those

what you mean with subscription

1 Like

he/she not asking about ads @saereV

1 Like

When a site offers push notifications, you will see something like this bell on the site’s landing page.

Once you have successfully subscribed to a site’s push notifications through the page, that widget will either stop loading or will convert to a means of unsubscribing (and the text when you hover over it will confirm that is why it’s there).

there interesting in your screen

first line it say via the what after it
is it Dissenter ?

i need some info

screen shoot from here brave://settings/help

could you try in private mode and to disable all extension and try and see if it work or not

try the above case while shield on and off

if it work while shield on then either the issue with one of your extension or with your cache or cookies

hope that help and have a nice day :slight_smile:

Via Disqus - Disqus is the commenting system installed and if logged into a Disqus account, you can ‘follow’ the site’s forum page. But Disqus long since abandoned maintaining the dashboard feed of content from followed sites.

screen shoot from here `brave://settings/help

Private mode with extensions disabled/Shields on/notifications allowed: No change. Brave popup (second image below) says I’m blocking notifications which as you can see in the first image, I am not doing.

thanks for the info

did you tried with shield off?

if that did not work could you go to menu then try to create new profile and see if it work fine or not

once with shield on / off

and see which one make it work

1 Like

I think you may need to allow cross-site cookies for Disqus and sites using this particular type of push notification. Test on Disqus by going to the site, opening the Shields panel (lion icon in the address bar), and changing the cookies setting to All cookies allowed.


I think enabling All Cookies Allowed, clearing the cache and restarting the browser did the trick. Just went back to the Chat Shack and push notifications are now successfully subscribed to, including receiving the initial welcome push.

Thanks to you and justsomeone1 for your assistance in resolving this issue! :hibiscus::hibiscus:



You’re very welcome. Don’t hesitate to reach out if you have any additional questions or issues.