Enabled Widevine by going to spotify.com and rebooting, but Amazon Prime still won't play

widevine

#1

Description of the issue:
Enabled Widevine by going to spotify.com and rebooting, but Amazon Prime still won’t play, just get eternal spinning cursor and eventually timeout
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Login to Amazon.com with Prime account, try to play any prime video on Brave browser Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)
Actual Result (gifs and screenshots are welcome!):
Cursor just spins:


Then hit timeout / Amazon error 7017

Which according to Amazon is:
Error 7017: This error occurs when there’s a latency problem relating to CDN performance.

Try these tips to resolve common connection issues:

  • Restart the browser and try playback again.
  • Try using the Watch from Beginning button instead of Continue Watching .
  • Check for Chrome updates.
  • Your Widevine Chrome plugin may need an update. Check for Widevine CDM Updates by typing chrome://components into the Chrome browser address bar, and then pressing Enter . Click Check for update under the “Widevine Content Decryption Module” item, restart the browser, and then try playing again.

Expected result:
Video plays
Reproduces how often:
100%
Brave Version(about:brave):
Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)
Reproducible on current live release (yes/no):
Yes
Additional Information:


#2

I actually just added this behavior to an issue just a moment ago. Seems to be related to CORS:

To workaround this, open your Shields panel and change the Cookie control option to Allow All. Not an ideal solution but will allow you to use the site until the issue can get resolved on our end.
Let me know if this works for you.


#3

Thanks for the update guys! Will actually just use another browser to stream Prime until this is fixed, rather than allow all cookies. Please update thread when fix is in place. Thanks again!


#4

Works now with:
Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Im running on MacOS. I also had to go to spotify to install the plugin, wouldnt show up at all on amazon site. Did a refresh (without reboot) and started working.


closed #5

This topic was automatically closed after 30 days. New replies are no longer allowed.