Empty sync chain

Description of the issue:
Sync chain is empty, so I cannot add my other laptop. QR code is unavailable

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Reproduces how often: Every time

Brave Version(See the About Brave page in the main menu):

Version 1.38.117 Chromium: 101.0.4951.67 (Official Build) (64-bit)

Type of devices currently running on the Sync chain in question:
Win 10 64bit

Additional Information:
@Mattches please help

Hi

@Marynarz_x3 Tell me what you see when you open this brave://settings/braveSync/setup

iF you seen nothing, try the following:

  1. Open brave://flags/
  2. Search for sync
  3. Check if Enable Brave Sync v2 is set to DEFAULT

@Marynarz_x3,
Before messing with flags, you first need to start a Sync chain on one device, then add your others. You’re saying the “QR” code is unavailable — on what device are you attempting to view the QR code? Can you please elaborate on how you tried to set Sync up initially?

1 Like

I had a sync code set up, already 2 machines are linked. I am trying to add a third machine to the sync code. When I select “View Sync Code” the box is blank, word count is 0.

With the QR code, its on the same screen as the blank sync code, I click view QR code and the message says “There was an error displaying the QR code, please refresh and try again.”

I dont need the QR code, I just think the error is related.

Thank you for your help @Mattches

@CerealLover
The flag for Sync V2 is set to DEFAULT

When I go to brave://settings/braveSync/setup i see two machines on the list. I want to add the third, but I am unable to because the Sync Code is blank. Word count is 0.

Hi

Check brave shield features @ brave://settings/shields as in image below. If not working test in a private window (Open Brave then hold CTRL+SHIFT+N)

@Marynarz_x3,
To be clear, when you say

Does this behavior happen on both of the other devices that are already added to the chain?

@Mattches Yes, both machines on the sync list have an empty box

@CerealLover Looks exactly the same.

Can you please open the QR and/or the Code words window again, right-click on it then select Inspect from the content menu, then click on the Console tab in the dev tools window that appears and send a screenshot of any output in the console window here?

@Mattches
console

Hello @Marynarz_x3 ,

It looks sync stuck in some the weird state.

On the page brave://settings/braveSync/setup is the device list displayed or it is also empty?

And could you please provide the screenshot of brave://sync-internals/ ?

We ask for it in almost each sync-related problems topic, because it indeed has a lot of helpful details.

Thanks.

There are two devices listed in brave://settings/braveSync/setup

Thanks @Marynarz_x3 ,

From the sync-internals screenshot I see that Sync Feature Enabled false , which normally would mean that sync is not turned on. I will look why that might happen, with the normal flow that shouldn’t like it is.

Don’t want to hijack but adding I am experiencing the same issue and have followed the steps outlined in the thread. My output also says Sync Feature Enabled False even though I do see my other devices synced and set the flag from default to enabled.

@websuperman,
Can you please tell us some additional details about your issue? Number of devices on your chain, what OS you’re using, Sync internals screenshot, etc?

There are 3 computers currently synced. I am using Windows 11 Pro. I have also noticed that any changes made to “Sync Settings” do not stick. Sync Everything or Customize Sync won’t stay on.

FYI. I fixed it by leaving the sync chain on the device that wasn’t working properly and then rejoining the sync chain. I had to rejoin a few times before it would actually take hold but now seems to be working properly.

Thank you. Seems to have worked for me too. I left the sync chain, and started a new one and now resynched all 3 laptops.