Emoji are monochrome line art, or blank boxes, Version 1.15.76 (but under Windows 7)

I don’t think there’s much more than can be said other than what it looks like on the screenshot I’m attaching, which is miserable. Any way to fix that under Windows? Why are the emojis not even natively supported by Brave? Firefox doesn’t have any issue with those and displays them correctly right out of the box.

could you offer the link to that website and what is your brave verion

and have a nice day

Version is in the title, aka latest. https://getemoji.com/

i have the same experience as you under linux did you tried chrome or not

and let me ask someone from the team @Mattches to help us here

and have a nice day both of you

1 Like

Chrome is just as inept ad displaying emojis, so it’s a shared issue. But I don’t expect Google to be competent enough to fix that - I do have a lot more faith in Brave though :wink:
If Firefox can do it…

Also have a great day.

if it work the same on chrome then the issue is one the chrome core as brave relay on it

Hello, @MaxiM_PL!

There are a few things to consider here. Emoticons (80 characters in total) came about after Windows 7 was released. While they were proposed in 2008 (Windows 7 released in 2009), they didn’t actually find their first implementation until 2010.

Microsoft did eventually go back and add some support for Windows 7, see this KB for more on that. The folks over at getemoji.com shared this limited support back in 2014. What I find interesting is how your screenshot renders many of the characters, but not all of them.

It could be that Firefox is patching (via gfx.font_rendering.fallback.always_use_cmaps, perhaps) some holes in Windows 7 support for Emoticons. This isn’t uncommon; Discourse (the platform we’re using here) does the same, IIRC.

What you could try doing is changing your standard font in Brave. You can do this by navigating to brave://settings/fonts, and selecting one of the Segoe fonts from the list. Emoticon support was added to the Segoe UI symbol font in Windows 7.

Which version of Windows 7 are you running, exactly?

Select the Start button, type Computer in the search box, right-click on Computer , and then select Properties.

image

Windows 7 Enterprise SP1, all up to date, always. And here’s how the same page looks like on Firefox, which uses Chromium:

BTW changing that fon’t won’t solve anything, as it’s the exact same line-art type of emoji in it. Win7 does not support “full color” fonts.

firefox is not chromium

Oh? Well, nvm that then. For some reason I thought that the new FF is Chromium based.

Unfortunately, Windows 7 doesn’t have a great solution at this time (and probably never will, since the operating system is no longer supported by Windows as of January 2020, and won’t be supported by Google and others in the near future). That said, there are some ways you can improve the experience in a Chromium-based browser. One such option is to install a font (and set it as your base font) which supports the extended character sets.

For example, below you can see a few screenshots of me installing https://github.com/eosrei/twemoji-color-font#install-on-windows, and setting a new Base Font for Brave in Settings, and then revisiting the getemoji.com domain. This won’t result in colorful emojis in Brave, but it will give you a broader character set.

I hope this helps!

1 Like