Email unobtainable


Description of the issue:
Email (Comcast) does not open.

How can this issue be reproduced?

  1. From Brave, clicking on the Xfinity tab.
  2. After logging in to Xfinity, clicking on read email.

Expected result:
Email should open and display inbox

Brave Version( check About Brave):
1.50.121

Additional Information:

Brave used to successfully open my email, but does not do so now. I get a screen that says something like, “We are now loading your email.” Nothing happens after that.

Firefox opens my email

Norton claims my Brave version is not current, and recommends updating to 1.50.125. However update action “failed.”

PC. Running Windows 10

@finarphin,
I was able to load Xfinity email without issue — I would recommend you try clearing the browsing data for the site, then trying to login again. To do this:

  1. Visit my.xfinity.com
  2. Click the “lock” icon in the address bar
  3. Click Site settings then Clear data
  4. Refresh the page
  5. Log back into your Xfinity account and try opening your email again

Please let me know if this works for you.

Thank you

You can clear data from your browser, or your email data is full of trash /spam mails. Try it delete old mails or try again later.

Thank you for getting back to me on this.

I could do steps 1-3, below. But I don’t know how to “Refresh the page.” So I skipped it and logged out. Then I logged back in again and still have the same problem:

Welcome to Xfinity Connect
We are now loading your email.

But it doesn’t load.

Thank you
John Reed

@finarphin,
Can you try logging into your Xfinity account, opening your Shields panel (lion icon in the address bar) and toggling Shields “off”, then see if you are able to view your email?

I tried this maneuver. It didn’t work.

Thank you.

Do a favor and check again, if it’s not updated. Up until moments ago, mine was telling me there was no update available. So I was getting confused as people were talking about 1.50.125. However, just moments ago it finally showed update available and did it. So update might have been something on Brave’s end.

I know we kind of skipped past on asking so I wanted to jump in out of curiosity. Does the same thing happen if you try in a private window? How about on a new profile (without installing extensions or changing settings)?

Essentially I’m hoping to rule out any issues with settings, extensions, etc. So testing on both of those would be a great help as well.


In case anyone reading this doesn’t know how to create a new browser profile:

From the hamburger menu Sync code that expires_ - Browser Support _ Desktop Support - Brave Community - Brave 4_30_2023 09_21_54 on the top right of your browser, you’ll choose Create a new profile.

Sync code that expires_ - Browser Support _ Desktop Support - Brave Community - Brave 4_30_2023 09_23_04

Lmao, weird. And now my browser just updated to 1.51.110. So yeah, definitely try to get update in when you can. Then will see if that or anything else I mentioned might help.

I tried both maneuvers. They both worked. I was able to obtain my email. Now what? Thank you.

It depends on which you’re referring to. If you mean just updating the browser fixed it, then nothing else to do. It just meant the version was the issue.

If you’re referring to the idea of Private Window and New Profile, then it means 99% chance that it’s an extension you have on your browser that is causing the issue. So the next thing to do would be to disable (sometimes have to remove, but try disabling first) your extensions and test. If no issue, then turn them on one at a time and keep checking until you find the culprit.

I was referring to Private Window and New Profile.

I had two extensions: Google Translate 2.0.13 and Adobe Acrobat 15.1.3.46. I disabled them. Then I removed them. Then I added Acrobat back. No effect on obtaining email.

@finarphin I apologize, I had so many replies that I delayed on getting back to you. If you completely removed extensions, should work. I see you mentioned adding again and it not working. But with extensions removed, did it work? If not, then have to look at cookies or differences in your settings.

With extensions removed it still didn’t work at first. But now it does work.

Thank you
John Reed

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.