Ebay verification- captcha won’t load

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:

Trying to log into ebay.com on ios 13.3 (iphone x). Brings me to a security page to verify my identity, but the captcha won’t load. Tried disabling the Brave shields, but it makes no difference.

How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Version 1.14.2 (

Mobile Device details

iphone x, ios13.3

Additional Information:

Does disabling Shields help? @sixsixty

Thabks for the response. Unfortunately, no. Tried disabling Brave shields, but ai get the same result. It gets stuck on “Loading Captcha …”

DIsable fingerprinting in shields on the the signin.ebay.com web page. Disabling shields on the initial homepageebay.com won’t fix it for the next page.

Similar issue on Airbnb site. Tried to submit a reservation request, which prompted a Load CAPTCHA button but nothing would pop-up. Had to reload my request in firefox (which did not require a captcha, hmm?!) Question: should I enable cross-site cookies, cross-site trackers, safe-browsing (disable) or something else?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.