During an update Brave asks for admin permissions "to become the default browser"


#1

I almost wrote a bug report about this last time. It happened when the update to 0.23.31 came in (but I didn’t realize that it was connected to the updates), it happened yesterday when the update to 0.23.39 came in and I have observed it several times before.

My OS is Windows-7.

Brave is installed in C:\Users\ (username) \AppData\Local\brave\ - this might be important!!

Actual behavior:

  • When Brave is open and an update is ready, A message window pops up, asking whether I want to allow a program to make changes to my system, the program is Brave.
  • I say no.
  • The following message is like this (actual message placed together with my setting regarding this) :
  • After clicking OK the update seems to finish successfully.

Expected behavior: Brave should update itself without asking for admin permissions AND it should honor my settings of “Brave is not your default browser” together with “Always check on startup: NO”

I was very happy that it was easy to install Brave for me alone instead of system-wide (Thank you and kudos for making it so!) and it normally works just fine in this state. Only the updater isn’t in sync with that - it should be able to tell that it’s not installed system-wide by the location of its own executable, in my case C:\Users\ (username) \AppData\Local\brave\Update.exe.
Thinking about it, these may be two different issues but they always appear together.
Anyway, there’s no need to remind me that it’s not the default browser, I purposefully set it up like this and should I forget about it, I would be reminded every time the (other) default browser opens.

It’s nothing serious, but it’s annoying.


#2

@tlaloc77, thanks for reaching out. Also, excellent reporting! Love to see all the relevant details up front!
Are you updating from a workstation at home or are you at work or somewhere that may have a network policy that restricts permissions on local profiles?


#3

@mattches Your question sounds as if you expected it to work the same way I did, hmm…
To answer the question:
I’m at work, but the laptop is mine and I have not set up any such or similar restriction on it. Further, I don’t know about any network policy that restricts permissions on local profiles, AFAIK, nothing is blocked or otherwise restricted here. Do you know some simple test to check for such a thing or could I look it up somewhere?
(FYI: I could become admin on my laptop, I just didn’t want to - I try to install & run everything with as little permissions as possible.)
In addition, I just searched my C: drive for “brave” to make sure that it’s not installed elsewhere by accident. It’s not. There is a shortcut/link on my desktop, everything else is installed below C:\users\ (username) \AppData
Thank you so far :slight_smile:


#4

Have you checked the permissions on the user\appdata\local\brave folder? For [username], all permissions properties should be set to “allow”


#5

I just checked. The checkbox for “Write protected” is not checked but contains a blue square (probably means that the permissions are inherited, for “Local” it looks the same). When I removed the blue square by checking and unchecking, I was asked to confirm removing “write protection” (then I hit Cancel). Not sure what that means, because even with the blue box I can edit files within the brave folder (don’t worry, I made a copy and restored the file after successful editing).
When looking in the Security tab, I see that I have full access (and everything else except special permissions) to the brave folder.

Would you suggest to explicitly remove this “write protection” by removing the blue square? It seems to be the only thing I could do regarding write protection.


#6

@tlaloc77, apologize, but I’m a little unclear about the particular dialogue/checkbox in which you’re referring to. Would you mind pulling it up and sending me a screenshot of what you see on screen?

Thank you!


#7

2 Screenshots:


The upper one shows the “blue square” within the checkbox “Schreibgeschützt” (Write protected).

The following one shows the content of the “Sicherheit” (Security) tab:

Sorry, it’s mostly German, not much I can do about it :slight_smile: