DuckDuckGo Result Visited Check Mark not working in Brave

This is a bug, but not sure if it is Brave or DDG. Today, I checked “Result visited Check Mark” in DDG’s settings. I realized I didn’t like it immediately, so turned it off and saved the setting. It still shows the check marks and continues showing new checkmarks on new pages opened. This happens on Brave in both my old Mac running High Sierra and my new Mac running Big Sur. It does not occur in Safari.
I haven’t tried other browsers. I’ve quit the app and it still shows upon relaunching. The only thing I haven’t done is tried a restart or other browsers. I’ve reported to DDG also, but not sure whose end this bug is on since it’s working in Safari but not Brave.

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

@752bfc1c933407ba6a19,
Can you share a screenshot of the check mark/behavior you’re seeing so that I can get a better idea of what’s going on?

Here is one, showing 2 articles I clicked on the page

@752bfc1c933407ba6a19,
I found the setting on DDG related to the check mark – I don’t seem to get it on my end if it’s turned off. Can you try clearing cache/browser data for DuckDuckGo and then see if you still get the same behavior?

I wasn’t sure what you meant about clearing cache/browser data for DDG (only?), but I didn’t see a way to do that. So I cleared it all for Brave browser. That took the check marks away, but I replayed the scenario and they are stuck again.

Did you first try to turn the check marks on to confirm that they show, then turn them off? Today is the first time I tried turning them on. The problem seems once they are turned on, they won’t stop showing even when turned off, unless Brave browser cache/browser data is cleared. I’ve confirmed this on 2 different Macs. Is there something within Brave settings hromethat is keeping the check marks showing that wouldn’t do so in Safari?

UPDATE:
Ok, weirdly, I just tried in Chrome and the check marks stay in Chrome also (same as Brave), even when quitting and relaunching Chrome. With Firefox, they stay also, but if I quit Firefox and relaunch, they disappear. Safari is the only browser that quitting the app isn’t necessary to make the check marks disappear, but Chrome and Brave are acting the same.

Can this be tweaked? Ideally, browser cache shouldn’t have to be cleared to make settings work (refresh doesn’t work), nor should a relaunch of an app be necessary.

@752bfc1c933407ba6a19,
You are correct that that shouldn’t be happening – looks like the setting is getting “stuck” in cache for some reason. If it were happening in only Brave/Chrome I’d assume it was an underlying Chromium issue, but if it’s also happening in FF I’m more inclined to think it’s an issue on DuckDuckGo’s end.

I’m curious – on DDG, can you go to Menu (three lines on top-right) --> General --> Show bookmarklet and Settings data, then adjust the checkmark setting and tell me if anything gets added (or removed) from the Cookie data field and/or the Settings in .JSON field?

Hmm … yes, see below, the one at the end changes to a “-1” in JSON and Cookies Data. It will save that way too, but the checkmarsk still appear. Anything to surmise from this?
{“kae”:"-1",“kp”:"-2",“kbc”:“1”,“kav”:“1”,“k5”:“1”,“kn”:“1”,“k18”:“1”}

UPDATE: This indeed was a DDG bug and DDF fixed the issue last night.