Drop-down menus don’t work

Description of the issue:
I have problems on various websites with drop-down menus.
They do not respond, I cannot click on the choices.
I have tried with Firefox and there are no problems.
I have cleared my cache and history.
I have tried also disabling all my extensions.
It has not made any difference.
Then if I copy the url, open a new instance of Brave and paste it, everything works fine.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Just opening a website with drop-down menus.
I think it happens only on websites where I have made a login, like bank services.

Actual Result (gifs and screenshots are welcome!):
Drop-down menus don’t work.

Expected result:
Drop-down choices can be clicked and respond fine.

Reproduces how often:
Very, very often, but not always.
This is very strange because as I said before, if I open a new instance, every drop-down menu works fine. I close the previous instance, and problem solved.

Operating System and Brave Version(See the About Brave page in the main menu):
Manjaro Linux KDE (Plasma 5.24.3, Kernel 5.15.28-1, Qt 5.15.3, Frameworks 5.91.0, Oxygen Theme)
Version 1.37.111 Chromium: 100.0.4896.79 (Official Build) (64-bit)
You see I have included specific details of the OS version I’m using but the result was the same on previous versions for many months.
If you need more details just tell me.


When the problem happens, try refreshing the page by pushing the F5 key few times in succession…
Also try flushing your DNS by opening Command Prompt as an administrator and entering ipconfig /flushdns, then restart Brave.

1 Like

I’m afraid F5 doesn’t solve the problem.
There is no Command Prompt in Manjaro. There is a Bash terminal.
Neither ipconfig nor flushdns are Bash commands.
In any case, thank you very much for your answer.

1 Like

I’m afraid the solution is to abandon Brave and go back to Chrome.
I have tested this drop-down menus problem on 5 different computers (Windows and Linux) and failed.
It’s a pity.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.