Dragging and dropping icon into shapes doesn't work to claim rewards

When I try to claim rewards, it requires me to drag the Brave Triangle logo into a certain shape (circle, square, or triangle). This is not working for me and I’ve tried 20+ times. How can I successfully do this so I can claim rewards?

1 Like

Does your device pass Safetynet? You can test here: https://play.google.com/store/apps/details?id=org.freeandroidtools.safetynettest&hl=en_US&gl=US.

I’m on a microsoft surface so it won’t let me download that link.

This seems to be an issue only on Microsoft Surafces. I too am unable to pass the captcha after multiple attempts and a system reboot.

Attempting to download SafetyNet Test and I am greeted with a requirement that I must “access the Play Store app on your device before installing apps”. Is there not a chromium based extension that could similarly verify this?

Edit: Btw this is a recent issue as I have been able to claim from this device for over a year with no issue up until this month.

This issue is also not limited to Microsoft Surfaces. I am using Windows 10 on a <6 month old laptop that I have successfully claimed Brave rewards for multiple times in the past. Please get this sorted out Brave. Rewards don’t stick around forever and we don’t want them disappearing.

Try zooming out and then claiming rewards

Hello, I am also experiencing the same problem. I drag and drop the BRAVE icon to the requested shape many times but it does not work. I’m on a Razer. Thank you

I use a HP laptop and have the same issue - tried dragging the triangle over 30 times and it continues to display, “Mmmm something’s not right” and shows another triangle to drag. Please advise to resolve.

1 Like