Drag and drop html file to browser does not open the file


#1

Hi Brave Team,

I would like to see opening an HTML file by drag and drop implemented.
Are there any security issues that cannot be overcome by opening HTML from the filesystem?
Steps to reproduce:

  1. Open Brave.
  2. Find HTML file from filesystem.
  3. Drag and drop onto browser (address bar and/or existing page).

Results: nothing happens.

Expected: Open the HTML file in the current tab. Optionally, open with a new tab (isolation of open file can be implemented that way)

FYI: Opera browser opens the file in the current tab.

Thanks,
Charlie


#2

Hi @un-CharlieH

What’s your OS and Brave information? You can go to about:brave to determine your Brave info. Also, I am able to do this on macOS without issue while using 0.23.39. (it opens the file in a new tab)

Thanks,
Lauren

cc @Mattches


#3

I’m actually unable to do this on Windows 10 myself (Brave V0.23.39).
Tried dragging and dropping into tab directly, into tab bar, and into address bar as well with no joy.
I was however able to perform this action in both Chrome and Firefox.
I’ll do some digging and see if this behavior has been observed before. Also, @LaurenWags, did you drag/drop the html file anywhere specifically, or does it work dropping anywhere in browser?


#4

Here’s where I tried to drag/drop the file:
URL bar - worked, file was opened in a new tab
Current Tab name (on the tab bar) - worked, file was opened in a new tab
Current Tab page (where the content displays) - did not work, file was not opened in a new tab

Let me know if there’s any other ways you’d like me to try on macOS! :smile:

Lauren


#5

Not necessary I don’t think, all those methods worked for me in both Chrome and FF. It may be Windows specific. @un-CharlieH, can we get your OS/Brave information? It’ll be hard to narrow down whats causing the issue without further information.

Thanks!


#6

Drop onto address bar, drop onto page -> no response.
OS is Windows 10,

Brave: 0.23.39
V8: 6.7.288.46
rev: a38be75ccb0f699f507b66c4d44b3b21d1677e25
Muon: 7.1.6
OS Release: 10.0.17134
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 67.0.3396.103


#7

That’s weird, never had that happen to me before. I also use a Mac and Brackets. The least I could say is try Command and Q at the same time inside Safari, Chrome, Brackets. I’d also reset my VRAM. Best of luck to you!