Drag and drop files to the browser does not work

Description of the issue:
When I want to upload something to some page (it is not an specific problem of a page) and I drag a file from windows explorer to the page it does nothing.

Exact URL of the website in question:
Nothing specific, but an example: https://www.mybib.com/#/projects/WBJQG1/citations
https://drive.google.com/drive/my-drive
But any page where you could drop a file to upload it (as in chrome, because I tried there and it works) here you can not.

Did the issue present with default Shields settings? (yes/no)
Yes

Does the site function as expected when Shields are turned off?
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No

Does the site work as expected when using Chrome?
Yes

Brave version (check About Brave):
V1.38.111 (May 3, 2022) 101.0.4951.54

Hi

@Enzor

Try to upload by drag and drop in private mode.
If working one of your extension might be the problem?
Restart Explorer, or restart device

If not working, try this: open Command Prompt as administrator and enter sfc /scannow to scan for system files.
Restart Explorer, or restart device

If not working; open Command Prompt as administrator and enter
DISM /Online /Cleanup-Image /CheckHealth
Restart Explorer, or restart device


Those things did not worked, but thanks!

Also, something I forgot to mention is that print screen is not working either (The one that you do with shift+windows+s, I modified the prtsc button to do it) but in chrome it does work.

@Enzor ,

In your reply 3, how did you upload that screenshot of the sfc /scannow results?

I did the screenshot and pressed ctrl+v (not always works)