Downloads to NAS stopped working in last update - file does not download, crashes Brave and Finder

Description of the issue:
Downloading files (eg PDFs using Fireshot Image Capture extension) works as it should if you select a local folder. However since (about) the most recent Brave update, trying to download a file to an attached network storage drive (NAS) does the following:
a. You click download
b. The download bar at the bottom appears
c. It appears to progress fine
d. The circle around the icon turns red and stays red.
e. Options are shaded out in right click on the downloaded file
f. The file has not actually downloaded.
g. The tab, and often the entire browser becomes unresponsive
h. Sometimes the network drives disconnect from the laptop
i. Finder becomes unresponsive.
j. Often using Force Quit on the browser does not even work.
k. Often need to restart the entire computer to get things working again.

Only happens saving to remote disks. Still works fine on local drive.

I initially thought this was a problem with Fireshot extension as I use it a lot to capture webpages and it crashed the browser/computer each time I saved to a network drive, but I have been in contact with Fireshot technical support who say:
“FireShot utilizes a standard Downloads API. I think the problem is related to how Brave implements the access to network drives. If it works in Chrome or Firefox, then I’d file a bug to the Brave developers.”
Fireshot works fine on the same laptop saving from Firefox to the same network drive that Brave crashes.

How can this issue be reproduced?

  1. Click to download a file (I’ve only tried this on PDFs, which I download a lot)
  2. Select a network attached drive.
  3. Click to download
  4. Wait for the crash.

Expected result:

For the file to successfully download to where I ask Brave to put it.

Brave Version( check About Brave):

Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (arm64)

Additional Information:
MacBook Pro M1 Pro 14" 2021
Running macOS Monterey 12.1 (21C52)

I’ve just upgraded to
Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (arm64)
but still it fails to successfully download to network storage without crashing, leaving a fixed orange circle around the small icon and crashing Finder at the same time!

Please fix this incredibly irritating bug where Brave can no longer save files to a NAS.
I have a little more detail which will be very helpful to you in fault-finding.

If you wait long enough (whether or not you click Pause & Cancel in the Downloads window), during that time the bug forces a disconnection of all the NAS drives every time.
If you then reconnect the network drives and download it successfully using another browser, you see that Brave does save a file like
Unconfirmed 265058.crdownload
which is the same size as the correct

If you don’t press cancel, after you reconnect the network drives and press Resume on the download it instantly changes it to the correct filename and is a successfully downloaded file.

So I hope this detail completely narrows down where the bug is for you to fix as I will have to change browser if it continues for much longer as I download files constantly.

“Unconfirmed 265058.crdownload” is an incomplete file, sort of like a container, waiting for the last items (sometimes), and waiting for the finished paperwork to be signed . . . and then, the container is sealed and label (PDF file name, in your case) affixed.

Any chance that you have a non-network, physical hard drive that you can externally attach to your MacBook Pro, and run the download to that “test drive” (in this case)?

Can you mount the network drives to your Mac’s Desktop – so you can see their drive icons in your Desktop window?

Where, or how remote, are the network drives?

When you say, “an attached network storage drive (NAS),” how is that drive “attached?”

Are the IPv4 IP addresses for all the devices on your local area network, set up manually?

If not, how are the IPv4 addresses assigned? How are, any IPv6 addresses assigned?

Can you PING the network drives? For example, let us say that the local area network IPv4 address for one of the NAS drives, is:

In a window, enter:

ping -c 400 -i 3

That is located:


If you can PING the network drive, then you might be able to keep that network drive more alive, more awake, during a download to it.

( tips: The -c flag is the count. The -i flag is the interval.)

How to PING on a Mac:

Sometimes, relaunching the Finder, before some data transfer, helps:

Ok, so firstly nothing has changed on my computer or network between Brave being able to save to NAS and now Brave crashing my computer except for an update to Brave. And this setup has been in place for years. So we should concentrate on Brave as the issue.

I attached an external HDD via USB and the download (of a PDF) worked instantly.
I attached an SD card via a hub via USB and the download (of a PDF) worked instantly.
I tried saving the download to the NAS (where all files are saved and no other program has any problem saving to or reading from) and the circle around the download icon at the bottom of the Brave window stayed orange. The progress of it in the Downloads window was at 0% for 4 minutes, then it did appear, but crashed Finder and I could not restart my system until I Force-Quit Brave and Finder. It took a long time before it rebooted rather than starting straight back up, as though what is happening is serious and needed fixing.

The MBP (my laptop-MacBook Pro) mounts (3 drives) automatically on boot from the NAS. It is a Synology 2 disk NAS that has wired ethernet connection to the router and is accessed by wifi. They are always visible in Finder both as drives under MacBook Pro, and the server itself is visible in Locations where you can mount other drives from it if you wish.

The IP addresses are automatically assigned by the router. Typically the NAS is at There aren’t any IPv6 addresses as far as I know, just IPv4.
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=2.943 ms
64 bytes from icmp_seq=1 ttl=64 time=3.574 ms

Yes the network drive does go to sleep, and if it is, it takes a few more seconds to complete a file transfer, but this is not the issue here.

So in summary everything on my computer, the NAS and the network is working perfectly and shows no sign of problem. The only problem that has suddenly occurred is that trying to save / download things via Brave to the NAS causes crashes. It can still save to local attached drives, but it does something nasty to Finder when saving to the NAS requiring force-quits and full restarts to fix it.

Other programs save to the NAS fine. Even other browsers can save / download to it without any problem. It is only Brave. Since its update. But it is my primary browser so it is a complete pain that I now have to either save locally and move across to the NAS or fire up a different browser just to download (which I do many times a day).


If you are willing to test . . .

  • clear cache and data
  • quit everything and restart your Mac
  • disable Wi-Fi on your Mac
  • disable Bluetooth on your Mac
  • start Brave Browser and allow 3 tabs at the most
  • run Activity and keep an eye on Brave Browser and the Finder

Then try your download / saving to a NAS drive.

Activity Monitor window on my Mac (running Mac OS 10.12 “Sierra”); I use 1 - 3 Brave Browser tabs:

Activity Monitor on a later Mac (@avid - using several tabs):

Ok, so I did Brave Settings / Security&Privacy / Clear Browsing Data / Cached images & files - All Time rangs.
Quit all apps.
Restared Mac
Turned off Bluetooth and WiFi.
Opened Brave with 2 tabs.

Not sure what exactly you wanted me to look out for in Activity Monitor, but here is a list of the several repeat tests I did.

When I opened Brave with no internet, there were 15 entries under Brave in activity monitor. By the time I had done several tests there were 20 entries. (A further tab had been opened several times and closed. The Energy Impact was between 0.4 - 1.1 at the start. By the end it was 1.0-2.0. This figure went down to zero when it was listed as Not Responding, but did not change while it was struggling to do the download.

Turning the internet on and loading the two pages in ActMon Brave Browser itself was at 209MB memory use. This barely changed the entire time.

The entry that changed most was the Brave Browser Helper (GPU) that started at 102MB and rose after each crash / failure to download by about 100MB, ending up using over 500MB and staying there while I write this in Brave.

The first download I did was to a local drive. After this download the BBH(GPU) was at 315MB, but that download completed successfully.

The first time I tried to download to NAS, Brave stopped responding, as did Shottr, the screen capture tool I used to capture the ActMon readings.
Nothing much happened to memory or energy usage of either Brave or Finder.
Finder did not become non responsive
After several minutes, the network drives were disconnected and Brave started responding again saying the download failed. - Download Error.

When I repeated performing a download to the NAS (after reconnecting them), this time Brave did not get listed as not responding. But taking a screenshot once again made Shottr stop responding, so clearly something locks up in the file system management. I think Finder only tells you it is not responding if you try to do something with it at this time. As I didn’t it didn’t say there was any problem. I cancelled the download and waited a few minutes for Brave to obey.

The third test I closed Shottr, just in case it was causing any problem.
But the same thing happened again - As I pressed to download to NAS, Brave just showed the download icon with a static orange circle round it. I waited, without performing any sort of file action. Eventually the NAS drives got disconnected then Brave came back to life and said there was a failure in the download.

Each time an Unconfirmed…download file appeared on the NAS.
I have a number of screenshots of Activity Monitor, but there is nowhere on this system to upload them for you to view.
So I cannot see anything odd in Activity Monitor.
All that happens is that when saving to NAS, the download progress circle doesn’t show progress, it just stays static full orange. It does download, but becomes unresponsive. Then it crashes the connection to the NAS, leaving the file as an Unconfirmed … file, then comes back to life.
Finder does not seem to be involved.
Nothing else misbehaves.
Did this do anything to help? It has taken almost 2 hours to complete this test and report it back to you so I hope you can move forward to diagnose and solve this now?


When testing, you might serve your self (you are the troubleshooter) well, with running diagnostics windows, such as the following three:

  • In the Brave Browser menu - Help - search for Task Manager, and open the Brave Browser Task Manager.

  • Also, run your MacBook Pro’s Activity

  • Also, run your Brave Browser Developer Tools >> Network (again, use the Help menu to find Developer Tools, and when the DT window displays, select the Network tab).

In a New Window for Brave Browser, enter


There, find in the the page: “Help improve Brave’s features and performance - Automatically sends crash reports to Brave”

A note about that: While crash reports are likely to be automatically sent to Brave . . . there may be a problem with crash reports showing up in the following, if using a New Private Window: So, in a New Window for Brave Browser, enter


If there are recorded (by Brave Browser) crash reports, you will need to keep track of them - copy and paste them into some text file on your Mac. So, when a crash occurs, you may send the Crash ID to Brave Support member @Mattches.

You have previously written:

“The MBP (my laptop-MacBook Pro) mounts (3 drives) automatically on boot from the NAS.”

Are you booting from the NAS? Or, do you mean that there “3 drives” among the drives of the NAS station; and the “3 drives” all mount automatically when you start up your MacBook Pro?

The Mac OS

“is responsible for the launching of other applications, and for the overall user management of files, disks, and network volumes”

The burdens upon the Finder, are many. Such burdens can overwhelm the Finder, when the Spotlight (and mdworker processes) are burdened with their duties re network volumes. You might go to the System Preferences on your MacBook Pro and prevent Spotlight from searching the volumes of your NAS station.

Brave Browser version 1.35.100 for Mac OS, has been an issue of late, re its crashes; for example:

Your MacBook Pro, recent Brave Browser installation/update itself, might be tripping along the edges of near-crashing, and your efforts to run your saving and downloading of files to your NAS station, might be incidentally running, or tripping, along parallel tracks (so to speak) . . . that may trace back to the general, sudden crash issue such as at that link.

@Mattches of Brave Support, will need to know the extensions that you have installed (they should all show in the Brave Browser Task Manager window . . . and what combinations, or individual, Enabling / Disabling of those extensions, you have performed . . . and what were your findings in that regard.

At least, disable and un-install the following extension and application:

  • FireShot (ext)
  • Shottr (app)

When you un-install Shottr (delete it from /Applications/ or run its un-installer if any), go to your

/Users/your_username/Library/Application Support/

directory and see if there is a folder therein, with “Shottr” (or “shottr”) in the name . . . and drag it to your MacBook Pro’s Desktop.

Next, go to your


directory, and see if there is an item therein, with “Shottr” (or “shottr”) in the name . . . and drag it to your MacBook Pro’s Desktop.

After which, you need to Restart your MacBook Pro.

After testing, you can move those items back to where you found them, and before you re-install Shottr.

If possible, you might test your issue with data copying to the NAS station, by making an Ethernet cable connection between your MacBook Pro and your local area network router.

If that works OK, but over Wi-Fi is not working well, then you know that there is at least some kind of data flow and timing (nodes negotiating with /talking to each other) problem, about which, the troublesome version (1.35.100) of Brave Browser, is stumbling.

Brave Browser version 1.35.100 might be stumbling because of the presence of a Chrome installation. You might test, by un-installing both, and then install Brave Browser 1.35.101 (is the latest).

I suggest that, because both applications might have some location where they have one or more files in common.

Have you tested downloading / saving JPG and other file types (other than PDF)?

And, re PDF, have you tested downloading / saving . . . with the Brave Browser switch in each of the two positions:

Just below the 1st / Original Post at:

there is a list of popular links, and some are where you can view, save, and / or downoad PDF files.

Might you test your downloading / saving procedure to your NAS station, using some of those PDF files?

During your testing, what did the 3 diagnostic windows indicate to you, re possible sources of the issue(s) you have with Brave Browser version 1.35.100?

@Mattches is the Brave Support member, who will know (much more) than I.

NOTE TO SELF: Issue might have a relation to:

Under a problem category “Brave bogs down during certain download situations and / or conditions.”

Everything on the computer and in the browser work absolutely normally at all times EXCEPT when Brave tries to download / save to networked attached storage. At that point processor utilisation goes very high / 100%. The browser stops responding. The download icon is static with an orange circle.
Eventually after a few minutes, the Mac loses its connection to all the NAS drives, not just the one being accessed and Brave starts to respond again.
The NAS drives reconnect without issue manually after that.
Brave downloads to a local drive with no issue.

Last week I updated Brave to the newest version
Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (arm64)

This crashing and failing to download to NAS that suddenly started happening after two or three updates ago, still happens.

Is there any point to uninstalling / reinstalling Brave?
If so, how can I protect all the favourites, shortcuts, remembered passwords, etc. so I don’t have to start again from scratch as a result of this bug?

Is there anything like clearing cache that could possibly help?

I imagine your answer is no to these as this is a very specific fault where recent versions of Brave interact badly with the new macOS on the new MacBook Pro A1 Pro attached to NAS drives. So when do you think I can expect this bug to get fixed?

Or is it now time to switch to Firefox?

Three further Brave updates and the bug introduced at the start of the year still prevents me downloading any file to a NAS attached to my Macbook Pro M1Pro without crashing the browser and releasing all the NAS drives and leaving files where the download should be.
Can you please help as this is getting VERY tedious?

Which NAS device? Qnap? Synology? When it fails, what shows up in the dev console? (screenshot)

Now on version:
Version 1.36.117 Chromium: 99.0.4844.74 (Official Build) (arm64)

While saving a PDF to my Synology DS212j NAS, I managed to get a screen shot of the dev console.

Clicking on the link shows the line of code where things go wrong - line10113:
// Do send the request (this may raise an exception)
xhr.send( options.hasContent && || null );
} catch ( e ) {

@domimikin ,


While using Brave Browser . . .

Use the Save As command, in order to Save this webpage (as HTML) to your NAS drive.

Repeat that test for a web page that has a lot of images.

Use whichever of your PDF extensions that you have installed to Brave Browser -AND- such extensions include the ability to save as a JPG and TXT file (not only as PDF) . . . to save a JPG file to your NAS drive . . . and to save a TXT file to your NAS drive.

Problems downloading PDF files:

Problems saving PDF files:

If the source for a PDF file, has a SPACE character in its path, then a download and/or save can fail.

The Discourse software used by the Brave Community, almost constantly polls your Brave Browser, and Brave Browser is supposed to respond (xhr).

That chattering is related to how the icon representing you, at the upper right of the Brave Browser window – when you have signed on – will add a tiny circular sprout, indicating a notification to you.

The polling (chatting) gets jammed up – re your screenshot of Developer Tools > Network status.

Possibly, Brave Browser processing is not working well with the “signing_required” processing (security, certificate(s) involved) of to < > fro traffic.

Some online recommendations, suggest (somehow) finding “fast signing” updates for the NAS drive.

But, from what you write, the problem is with Brave Browser is effectively having S-L-O-W S-I-G-N-I-N-G fatigue when combined with other Brave Browser duties / processes.

Downloads not working, shows # in mac OS dock icon but file is nonexistent - #41 by jordanklein

Online, look for Mac OS / UNIX / Linux man pages, re:



Those errors in the console seem related to Brave forums. Does disabling shields globally (via brave://settings/shields) help with this issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.