Downloads not saved when folder or filename changed

Description of the issue:

When trying to download a file, when I change the folder or filename in the Save dialog,
frequently the file is NOT downloaded. The download does not appear in the status area at the bottom of the screen, and it is not listed in the Downloads list. No error is reported.
The download just does not happen, with no indication why.

How can this issue be reproduced?

  1. Set Preferences to prompt for download location.
  2. Click on a file link (usually a PDF) to download it.
  3. In the Save dialog, browse to a different folder, and change the name of the file.

Expected result:

The file should download and be saved in the desired location with the desired filename.

Brave Version( check About Brave):
Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (64-bit)

Windows 10 2H2021

Additional Information:

This has been going on for months.
It does not happen all the time, but most of the time.
No problem using Chrome, just Brave.

What are your settings under brave://settings/content/automaticDownloads and brave://settings/content/pdfDocuments? Does changing them, and then changing them back, help?

1 Like

glennman,

Settings are as shown in your example:
Sites can ask to download multiple files
Open PDFs in Brave

Last night I opened a PDF in Brave, and it displayed in the browser.
I clicked the icon to download it, changed the folder and filename, and it downloaded fine.

I’ll try to find a repeatable example of the failure.

glennman,

May apply / interest:

Found another problem with might be related.
In this web page

when I click the link to download the HowTo Manual
( http://pdf.lowes.com/productdocuments/f4279369-7172-4459-8dec-c689d34997d0/10494698.pdf )
The window flashes once quickly, then nothing else happens. No download.
If I open a new window and put in the PDF url, it does download the file.
That download works whether or not I change the name, including with spaces in the name.
Maybe that should be reported as a separate problem.

1 Like

I have not managed to reproduce your bug. Since you say the window flashes into and out of existence, could you try downloading a PDF for which this happened, once with Shields disabled, and once with extensions disabled, to see if that makes any difference?

Glennman,

Any chance there is some file and folder glitch? Maybe take a look at:

https://www.dell.com/support/kbdoc/en-us/000137238/understanding-file-and-folder-permissions-in-windows

Any chance, there are Known Good Ones – of folders in which, you have consistent success of downloading test files (txt jpg pdf) to?

Unfortunately, I have not been able to reproduce the problem reliably.
I was just in a page and tried to download a PDF file.
When I changed the name of the file or the folder, it did not download.
I opened the same page in another tab, and it worked fine.
I guess I’ll just have to live with this issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.