Download on Download bar information isn't displaying correctly

Description of the issue:
Hi, I updated Brave to version 1.29.80 and I’ve noticed on the last two versions at least that when I download a file via Brave, it isn’t displaying the information properly for the download on the download bar.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Just download a file. I don’t have a Windows or Linux machine to test on.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Displaying the information of the file downloaded, and the ‘Keep’ button.

Reproduces how often:
Always. I’ve only noticed this behaviour on the last two versions however I don’t download via Brave all the time as I tend to use JDownloader2.

Operating System and Brave Version(See the About Brave page in the main menu):
Mac OSX Big Sur version 11.5 and 11.6.
Brave version 1.29.80

Additional Information:

This could be an issue specific to MacOS as I can’t reproduce it on Windows 7.


Another report on MacOS about the same issue:
"Keep" button do not show word "Keep" after download file

@Mattches might have to alert developers if you are able to reproduce the aforementioned issue.

I’m not able to reproduce this on my end. It does appear to be a graphical anomaly rather than a bug – I’m assuming that you can still select the Keep option, is that correct?

Yes, both buttons work fine. I’ve tried changing the screen resolution to different scalings without any success. The website I’m going to is ( and I’m downloading the DMG file there. Hope that helps.

1 Like

I’m actually wondering if it’s an HWA issue – can you try temporarily disabling Hardware Acceleration and test to see if the issue persists?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Turned off hardware acceleration and downloaded the DMG file again. Download message still looks the same.

1 Like

Thank you for testing anyway – reaching out to the team to see if anyone else can reproduce this.

@Mattches The same happens on my new Macbook Pro 16’’ even with Hardware Acceleration disable. Definitely a Brave Browser issue.

Thank you for reporting.
I’ve opened the following issue for the developers to address:


Looks like we’ve pushed a fix for this already – thank you both for bringing it to our attention: