"Download" button for some files not working

Description of the issue: On 2 sites so far (Dungeon master’s vault and Lcp editor) you cannot download anything. And i’m guessing it’s the way they do it but no matter shields up or down it doesn’t work, on google it works, on other platforms it works. So you click download LCP(LCP editor)or upload files(DMV) and for DMV it sends you to a blob it cannot use. For Lcp editor it completely doesn’t work, no matter what you do. Although LCP editor is known to have issues, DMV isn’t and also LCP editor works on different platforms(google, safari, etc.)

How can this issue be reproduced?

  1. Clicking “Download”/“Upload files”

Expected result: You click download and the file downloads to your files and you then can share it or save it.

Brave Version: 1.61

Mobile Device details: i tried on multiple devices and it did the same thing, either turnt to an unusable blob(as the sites can’t accept a blob) or just outright refused to do anything. I tried on an Iphone 13 and a iPad 9th gen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.