Don't remove MacOS Mojave 10.14 support on Brave, even if Google now announced to us that they will do that

Few hours ago Senior Dev reported us the no interest of keeping MacOS Mojave support on Chrome.
In 2 years they are removing the 2 best MacOS ever released, before Apple started to downgrade features in MacOS (and obviously adding some other too), especially related to all backup workflows, that now are more complex, but even to permissions and multiple other things. We reported the new downgrade for external drives implemented in MacOS 12/13 previously, but this is not the point now.

We explained already here why they should keep support for such MacOS, and later again here.

Now the point is: we are trying our best to revert such decision, like we wrote here, but it’s important that other chromium based devs know about such problematic and evaluate to continue support, if this is technically possible. Remember that MacOS 10.14 is not like all other MacOS released by Apple, so removing such MacOS is not like removing Catalina, High Sierra etc.

If there are question why MacOS Mojave support is so important, just write directly to us. We already experienced the direct consequence of removing MacOS on Chromium on all browsers and apps few months ago with Sierra.

Please keep in mind that this is not just related to Chrome, but even Chromium based browsers, Mac Apps using Electron, and all other Mac Apps too (because if one is starting to remove support, especially big brands, the other will follow much easier*). So be open with your mind and don’t write “i’m not using Chrome or Mojave, doesn’t matter for me”.

There is the possibility that Google maybe know about some changes with Xcode, like we wrote here, but probably is not the case. If this is true, then the situation would be much worse, if now Apple really decides to remove multiple MacOS, like we previously reported with out thoughts.

*Keep in mind that almost 70%+ of all browsers available for MacOS (80+) are Chromium based.


In case you will not doing that and Google will not keep support for Mojave, please provide directly link to download a browser version compatible with up to MacOS Sierra and one up to MacOS Mojave, instead of just download last version. Avoid auto update of the app too. So don’t install new incompatible app automatically, which make no sense at all.

Mirror post of https://github.com/brave/brave-browser/issues/28909