Doing a search within the Settings menu isn't showing results


Description of the issue:
The search bar in the Settings page on MacOS does then doesn’t show matches

How can this issue be reproduced?

  1. Select Settings from top right hamburger menu.
  2. Click magnifying glass to start a search
  3. Type “bloc” (do not hit enter) - you will see lots of matches for “block”
  4. Now add a “k” to the end to spell “block”. All matches disappear, even for “block”.
  5. Now hit delete/backspace and go back to “bloc”. Matches reappear.
  6. Hit delete/backspace once more and go back to “blo” - no matches.
  7. Now you can’t find a match for “block” no matter what you type, and other searches give odd results (I tried typing “brave” after deleting “block” and got a link to the passwords settings menu, which had no matches at all).

Expected result:
Obviously, searches for words that match should be returned. It’s a Search bar.

Brave Version( check About Brave):
1.42.95 Chromium 104.0.5112.81 (arm643)

Additional Information:
This happens on Private Browser widows as well.
The only way to get my search capability back is to close the tab and open a new one (although it still breaks if you repeat the steps I listed).

Can you show a screenshot? Asking because it works for me. Might be difference in is that I’m on Windows, but kind of curious.

Hi

On my side, Windows 11, latest Brave; In addition to the “block problem”:

  1. When searching for ‘social’ it always gives no results.
  2. When searching for ‘profile’ gives no result after I searched any other words before.

Note: However I found that clicking F5 give results for any word!

Hey, yours also not pulling anything up when typing in block? If so, makes you wonder what’s going on, as can see mine worked.

Kind of curious if @Mattches has any insight on this.

1 Like

@Saoiray @CerealLover @timp,
While I do not get the exact results shown in your examples, I do see some strange behavior. For me, Block is found when typing in block, bloc or blo. However, if you delete then retype the word, less results are found until eventually it defaults to something in the Passwords page in Settings.

I’ve forwarded this information to the team for review as there’s definitely something fishy going on with the search function in Settings.

2 Likes