Does brave can remember settings?


#1

Every time I restart Brave, it opens a new tab asking me to create a lastpass account. I already have one. Can this be avoided?

Also every time I go to trello, it asks me “Allow trello.com to show desktop notifications? Remember this decision” I answer no but it keeps asking me after every restart.

Extremely annoying.

Also there is no option to show/copy/save the password generated by lastpass for a new website registration, like here for example. So I will probably need to reset mine for this very website. No trace of it anywhere.

Thanks :slight_smile:


#2

It seems you enabled Saved sites settings and permissions under Preferences > Security. Turn off that option will help with your LastPass and Trello issue.

I’m not sure about this. Can you elaborate more? Did LastPass show same behavior in Chrome?

If you used LastPass, your passwords should be saved to LastPass vault.

Best :slight_smile:


#3

Thanks for your reply

It seems you enabled Saved sites settings and permissions under Preferences > Security. Turn off that option will help with your LastPass and Trello issue.

True, changed. Thanks.

I’m not sure about this. Can you elaborate more? Did LastPass show same behavior in Chrome?

No, it’s particuliar to Brave. All other browsers create a small window offering the option to copy the password, generate a new one and use it.
Then it’s copied in the password field and saved in the lastpass vault as ‘generated sitename’.
Brave OTOH just create it and use it in one single step, right into the password field. It’s not saved either.
Am I being clear enough? Best way to understand it is to try with different browsers to register on a new website and compare.

How to reproduce:

Go to a website where you want to register,
enter username/email
click on the generate icon in the password field

Brave will fill the field with an obfuscated password and that’s all whereas all other browsers will open a small window having options.

Also what about that new tab opening each time I start Brave welcoming me into lastpass. I’m not new to it, I’ve been using it since inception and have it installed in IE, Palemoon, Firefox, Opera, Chrome, Vivaldi ans Epic. When I want to login I just need to click on the icon in the bar. No need to open a new tab for that. I know where that icon stands.

Tried to upload screenshots, but not being allowed to!


#4

I’m sorry for really late response @kunta-kinte. Forgot to follow up this; my bad. :expressionless:

I’m trying to reproduce it on Brave with your steps above. Is this how it should work?

Is this still happening? I’m not sure about this because it’s not open the welcome tab every time I start Brave (and it’s still logged to LP).


#5

No worries. Been busy too.

Yes however it’s confusing. All other browsers open the password dialog when you click on the […] in the password input field; with the latest Brave 0.20.42, one has to right click to reproduce what you’re doing. I discovered that by trial and error while visiting https://senglehardt.com/demo/no_boundaries/loginmanager/index.html

No big deal though, at least there is a dialog available. Might be a lastpass issue as well. Brave can’t remember my lastpass email even though I’ve instructed it to do so numerous times - each time I fire it that is.

Every single time I start Brave. No exception. I have to reenter my email manually while login in too.


#6

Yeah, it used right-click to show LastPass on context menu. If I’m not wrong, LastPass icon in field only used for autofill.

I’m unable to reproduce it because it’s always keep me logged in. Will cc @LaurenWags and @sriram for additional help.

Also which Brave version and OS are you on?


#7
Brave 0.20.42
V8 6.4.388.41
rev 096c7cb
Muon 4.8.2
OS Release 6.1.7600
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 64.0.3282.140


#8

@kunta-kinte do you clear any data on exit of Brave? Meaning, if you open Preferences and go to Security, in the Private Data section are any of those toggles on?

Lauren


#9

hi @LaurenWags good point. most are. you might be right on track to the solution.

the problem might very well be sitting on my chair lol…

Arcane settings like autofill/autocomplete. I always disable those in every browser I use and I use several for specific pages (FF 3.6.28, IE9, Vivaldi 1.13, Opera 48, Epic 60, Maxton 5, Palemoon 25, and that’s right no Chrome). If the configuration/settings page is too different that what I’m used to, I will likely miss the setting.

Thanks for your help.


#10

No problem @kunta-kinte - Glad my question helped :slight_smile: Going to close this thread for now, but please continue to reach out with issues/questions.

Best,
Lauren


#11