Docusign account page unable to load templates or view envelopes

Description of the issue:
Opening a DocuSign account to manage templates and view envelopes presents an error and no data is loaded. Managing the account in Chrome works as expected. After clearing cookies and site data the issue persists.

Viewing the Network tab of dev tools, there is a request to the “batchEvents” docusign endpoint that returns a 500 Internal Server Error, while in Chrome the same request returns a 201 Created result code.

Exact URL of the website in question:
https://app.docusign.com/templates

Did the issue present with default Shields settings? (yes/no)
yes.
The issue is present with “shields up”

Does the site function as expected when Shields are turned off?
No. The issue is still present with “shields down”

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
no

Does the site work as expected when using Chrome?
yes

Brave version (check About Brave):

Version 1.28.106 Chromium: 92.0.4515.159 (Official Build) (64-bit)

@freezeyjn,
Thank you for reaching out.
Can you attempt to open/view the site and, when the site fails to load, open the browsers Dev tools window and share any output from the Console tab here (a screenshot of the output/window would be just fine).

Menu --> More tools --> Dev tools --> [Console]

There are a few javascript errors in there.
I have attached two screenshots, one from Brave where we have a problem, and one from Chrome where the page loads as expected.


1 Like

Thank you for the information. Allow me some time to dig into the issue and pass this information on to the team.

Appreciate your patience.

From a clean Brave profile, uploaded a pdf. @freezeyjn Didn’t fail yet, what steps did you take to cause an error? Does it occur in private window mode?

1 Like

I just tried from a private window, and that does work. If I open a private window and login to DocuSign, I see the templates and everything there as it should be.

I also tested using Brave on my second computer (running latest MacOs), and it works there as well.

My question now is how do I clear whatever is broken out of my Brave profile so that docusign will work normally? I have already gone to site settings and cleared everything related to docusign.com, account.docusign.com and app.docusign.com - but that didn’t make any difference.

Hmm can you disable all the extensions and try in normal window mode?

And that found the problem.

Disabling all extensions resulted in the page loading as it should.
I enabled extensions one-by-one until it broke again, and then tried loading the page with just the one extension that was the last to turn on when the page broke – the culprit extension was “Change Timezone”, which I had used a few months ago for debugging some javascript.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.