Do not directly download PDFs


#1

I think it would be a good option to ask what we want to do with PDFs and not download them directly


#2

We currently display PDFs in the browser and the user has to manually choose to download. Are you experiencing something different?


#3

Sorry, it’s true this is corrected, sorry, thanks for your quick response!
I’m a mess


#4

No worries, we appreciate reports from the field! :smiley:


#5

I have checked it in windows, linux and IOS, but on android it asks for permissions to download the PDF file, it does not let visualize it.
Thank you very much for your prompt response, I would love to be able to optimize the search engine, look for the faults and solve them quickly, I speak to all my friends about this new technology, I encourage, it seems amazing and it has me in love
-Sorry for my bad English-
:sweat_smile:


#6

Ah, our mobile releases may behave differently. I will move this topic to the proper category.

@Serg when you have time, we may need to look into PDFs on Android ^


#7

Perfect, if I can help with anything here I am :grin:
I have a Nexus 5 & Android 6.0.1


#8

Much obliged! Please join us here : https://community.brave.com/c/contributing

The Android group would love to have some extra hands trying our new features.

Thanks!


#9

Dunno about Android, but I have been trying to view and download an online .pdf magazine for the past 45 minutes but only end up with a blank page on my desktop using Brave 13.4 on Ubuntu 14.04 AMD 64 bit. Tried putting the shield down and disabling HTTPS everywhere (the magazine is not HTTPS) and allowing ads etc, but nothing seems to want to let me see or download this .pdf. I would prefer to have the original problem mentioned here for Android users–download the .pdf–I can always delete later. Right now I can’t read or download the material that I want.


#10

@wimel it asks permission I suppose only once at very first time to access your storage, please let us know if not. It downloads without any prompt on a next attempt. @Q1766 the latest stable on desktop is 15.2, please upgrade it, run this in terminal
sudo apt-get install --only-upgrade brave
sudo apt-get upgrade brave


#11

Thank you, Serg. I have upgraded, but still have the same problem that I’ve had since I first installed Brave in that I can’t seem to enable flash. The “Enable Adobe Flash Support” button is greyed out. I’ve done everything in the wiki–Adobe Flash is installed and works fine for Chrome or Firefox and I also have pepperflash (I installed it free from ubuntu Software Center some time ago). I’ve done everything else listed in wiki, but homestarrunner just shows a blank white square and tells me to enable flash. I can’t download anything that is in .pdf form. Not sure what to do next.

Post updated; Sorry, but it turns out that I haven’t upgraded. Those terminal commands seem to have installed a lot of files, but Brave still shows me with ver 13.4. And it still won’t dispaly any .pdf sites. It also won’t display parts of sites, which makes it somewhat less than useful. I think i will give up on this until it gets out of Beta-I don’t have the time to waste.


#12

СС @sriram, @alex on that


#13

@Q1766 Just to confirm do you see a /usr/lib64/chromium/PepperFlash folder? If this folder is not available flash switch under preferences will be disabled. If you do not see that folder then please visit this link and download the file, create the above folder and then extract manifest.json and libpepflashplayer.so into the folder. This will enable flash on Brave

Regarding the pdf, could you open the pdf and then open developer tools (Ctrl+Shift+I or F12) and check console tab for any error


#14

Thanks for trying to help, but after completing what you suggested, there is no change. Flash button is still grey and inactive, and right clicking on ‘homestarrunner.com’ gives the message that I should "enable flash’.

I don’t understand what you suggest about .pdf’s. If I click on a .pdf URL, nothing happens. If I click on a .pdf link inside a site, the same happens–nothing. I don’t know if you are suggesting that I download the .pdf with another browser and then use the developer tools or if you are suggesting I use the context menu to "Instpect Element’? In any case, developer tools are far above my understanding. The info there means nothing to me. I wouldn’t know what to look for.

I do have a PDf Viewer installed as an extension, but it doesn’t seem to be doing much good.

I really would like to use Brave, but my overall skill level is very modest. I’ve set it as my default browser since I first installed it, even though the settings tell me it is NOT my default browser. It just doesn’t seem to like me.


#15

@wimel - does your Android device have a PDF reader (such as Google Drive) installed? I’ve found I can download the PDF but I can’t visualize the PDF without a reader on my device.


#16

Yes, my device has a pdf reader, it only asks for permissions the first time is correct, but ideally it could read the pdf online, without having to download anything or have to give permissions.
When I download the file if I can read it correctly


#17

@wimel Its the same behaviour with Chrome on Android. It auto downloads the PDF file and opens up in the PDF reader. I don’t see an option to open a PDF within the browser itself.


#18

Ok thanks, really the browser works very well, I do not usually use android devices so I do not know if it is normal, it was just a suggestion in case it could be solved, thanks for the help and interest shown :heart_eyes:


#19

@Q1766 Could you open the pdf in a new tab on Brave and then press F12 to open developer tools. Once the developer tools window opens please select Console and take screenshot and share it here.


#20

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.