Do I need to migrate from Dev to Release (v.1.58)?

I just ran across this (had not seen it before):

and this:

“Brave will no longer support or update the “Dev” channel version of the browser. This means that users that are on Dev channel will no longer receive browser updates. We highly recommend users migrate from Dev channel to Nightly, Beta or Stable versions of Brave.”

The migration procedure (Dev-to-Release) seems a bit complicated to me.

Is there a compelling reason to migrate to Release in v.1.58?

(I was aware that my version of Brave couldn’t be updated under Mojave, but had not known of a recommendation to replace Dev with Release.)

Thanks.


Version 1.58.109 Chromium: 116.0.5845.163 (Official Build) beta (x86_64)

Mac OS Mojave (10.14.3)

@mk7z,
Well our dev builds are no longer receiving updates which is the main reason to migrate. However if you’re wanting to continue using an outdated version anyway then you should be fine running/staying on that version of Dev build.

1 Like

> However if you’re wanting to continue using an outdated version . . .

@Mattches Thanks, it’s not that I want to.

My old MacBook Pro’s hardware, though it so far continues to operate just fine, doesn’t support any macOS version beyond Catalina.

Though I could install Catalina (replacing Mojave), since at this point even that OS version is ‘old’, can you estimate how long future Brave updates are going to support Catalina?

@mk7z,
Probably for a good amount of time.

And yes I didn’t intend to make it seem like it was your desired choice, just that you “want” to given your OS.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.