DNS over HTTPS issue of Brave Desktop browser

The DNS over HTTPS function of Brave desktop browser doesn’t work, but the one of Edge desktop browser is OK!
(The version of Brave is 1.11.104 Chromium: 84.0.4147.105 (64 Bits))

I have changed the IPV4 \ IPV6 setting of my Ethernet card as below.
1.1.1.1
1.0.0.1
2606:4700:4700::1111
2606:4700:4700::1001

And I have set the flag below as Enable.
brave://flags/#dns-over-https

But when I input the address in Brave browser
https://1.1.1.1/help

Debug Information
Connected to 1.1.1.1 Yes
Using DNS over HTTPS (DoH) No
Using DNS over TLS (DoT) No
Using DNS over WARP No
AS Name Cloudflare
AS Number 13335
Cloudflare Data Center TPE

Connectivity to Resolver IP Addresses
1.1.1.1 Yes
1.0.0.1 Yes
2606:4700:4700::1111 No
2606:4700:4700::1001 No

However, when I input the address in Edge browser
(The version of Edge is 84.0.522.52 (64 Bits))
https://1.1.1.1/help

Debug Information
Connected to 1.1.1.1 Yes
Using DNS over HTTPS (DoH) Yes
Using DNS over TLS (DoT) No
Using DNS over WARP No
AS Name Cloudflare
AS Number 13335
Cloudflare Data Center TPE

Connectivity to Resolver IP Addresses
1.1.1.1 Yes
1.0.0.1 Yes
2606:4700:4700::1111 No
2606:4700:4700::1001 No

Please kindly fix the DNS over HTTPS function of Brave browser.
Thank you.

PS:
My Notebook:
Window 10 Home 64 Bits
Version: 19041.388

the dns over https still experiment flag for linux it does not even supported but idk when they will enable it

1 Like

On MacOS, it appears it is working as intended… Not sure on windows…

These are st*pid suggestions, but may work…

  1. Exit brave and restart it.
  2. Clear your cache and try accessing 1.1.1.1/help
  3. Maybe restart your interface… like ifdown/ifup on *nix
  4. Reboot windows

Edit: Trying on my work windows machine fails… No admin right to mess with network cofigs and the flag is missing from my brave install… :expressionless:

1 Like

[quote=“megaspaz, post:3, topic:149483”]
Reboot windows
[/quote]Thank you all firstly.

When I input the address in Brave browser
https://1.1.1.1/help
, Debug Information shows
Connected to 1.1.1.1 Yes
Using DNS over HTTPS (DoH) No

It means that Brave browser connects to 1.1.1.1 (DNS) sucessfully.
So I need not to input “ipconfig/flushdns” in cmd of Window 10, and I need not to reboot windows, either.

Yeh… I did say the were stupidish suggestions… I don’t have any windows machine except for work and d.o.h. is working fine on mac… hopefully someone with a windows can either reproduce your issue or knows something more in depth about d.o.h…

1 Like

Brave and Edge browser are based on Chromium.
Why the DNS over HTTPS function of Brave desktop browser doesn’t work?
But the one of Edge desktop browser is OK?

1 Like

If you use the DNS servers whch are in the source code of chromium,
and have set the flag below as Enable, you can use DoH fuction!
brave://flags/#dns-over-https

If you use Cloudflare DNS, you can check if DOH is OK in the webs:
https://1.1.1.1/help

However, if you use the Dns below, you can’t enable DoH fuction!
security.cloudflare-dns.com
1.1.1.2
1.0.0.2
2606:4700:4700::1112
2606:4700:4700::1002
This is becuase there is no 1.1.1.2 DNS in the source code of chromium.

PS:
The source code of chromium includes:

unfortunately that flag is not supported in linux :sob:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.