Disabling Redirects Not Working

Hi! I’m using this website, but every time I pause or play, it redirects me to ‘https://fillingimpregnable.com/’. (it has more char after the last /) after it takes me there, it sends me to a spam website. This doesn’t happen with any other sites. I’ve disabled redirects, turned on agressive ad blocking and tried some other things, but none of it worked. Is there a way to stop it from sending me to that site?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.