Disabling Brave Automatically Switching Windows when Websites Finish Loading

I’m running the updated v1.58.129 (Sep 20, 2023) build and I have the problem where I would open a website in another window to load and switch windows. When the website loads, Brave would automatically switch back to that window. How do I stop this from happening?

1 Like

Not entirely clear on the behavior you’re describing here. Would it be possible for you to share a short recording of it in action? If I understand correctly you’re talking about something like this?

Hi @Mattches ,
Thanks for the reply. Here is a video of what I’m referring to. To clarify what happened in the video: after I created a new private window and entered a website, I three-fingered swiped back to my original window. However, after the website loaded, Brave automatically switched back to that private window without me doing anything.
(Brave Community doesn’t allow new users to upload content for some reason so here is a link to the video: https://youtu.be/LmXpzBXz6SQ.

Thank you for the video confirmation. Strange that that is happening. I do not see this same behavior on my end:

I’ve asked a couple macOS folks from the team to take a look at this because it looks like you’re using a brand new profile even and its still showing this behavior so I am not sure what could be causing it, unless there is some system specific setting I’m unaware of that controls this but I find that unlikely.

PS: Couldn’t help but notice your YT page and Rodtang was robbed in that fight!

1 Like

Thank you for the response and I couldn’t agree more!

1 Like

A couple things — first, can you ensure that you’ve updated to the latest build (v1.58.131 at the time of writing this) and tell me if the issue persists?

If so, can you please also tell me what tools you’re using that I see on the system top bar?


:point_up: Are any of these related to Window/layout management?

1 Like

I have updated to the latest build and the issue still persists. The tools I am using (in order from left to right are):
Quicktime player (solely used to record the screencast)
Notunes (used to block apple music from automatically opening when my bluetooth earbuds connect. I disabled this app for testing and the issue still persists)
CleanmymacX (antivirus, junk scanner)
Language selection for keyboard (Built-in)
And the others are basic applications.
None of these should be related to window/layout management.
Thank you once again for your time and efforts.

I have this same issue, hella annoying. Please help!

BTW, love Rodtang too so this issue’s gotta get prioritized :facepunch::facepunch::facepunch:

1 Like

Can you share some additional info with us? What version of macOS are you using? Do you have any extensions installed at this time? How long have you been experiencing this issue?

Additionally, I’ve logged an issue for this for the devs to review:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.