Disabled menu items in Azure portal

#1

Description of the issue:

Some menu items are disabled by Brave when logged into portal.azure.com

Steps to Reproduce:

  1. Launch a new tab in Brave browser with Shields down
  2. Login to portal.azure.com
  3. Search for resource Azure Active Directory in the Search bar
  4. Click on Azure Active Directory(AAD), this loads the AAD sub-page with a list of menus
  5. You’d notice that under Manage section, except for `User settings1 menu item everything else is disabled. Clicking on them results in no action

Actual Result

Expected Result

Reproduces how often:

100%

Brave version (about:Brave)

Brave Version: Version 0.58.16 Chromium: 71.0.3578.98 (Official Build) (64-bit)
OS Name: Microsoft Windows Server 2016 Datacenter
OS Version: 10.0.14393 N/A Build 14393

Reproducible on current live release (yes/no):

Yes

Additional Information

This works fine on Firefox Quantum (64 Bit)
Actually this portion of the site on Azure was working fine on Brave until a couple days ago but seems like MS has made some UI updates on their end … I say this because the Azure Portal looks a bit different that a few days ago… I think this could be related to that

#2

Execellent write-up @bravepc!
Can you tell me what your default Shields (and your Shields panel) settings are configured to (for the panel, open it on the site in question, if you don’t mind).

Additionally, if you click the lock icon on the left-hand side of the address bar, are there any permissions being blocked (or allowed for that matter) shown here?

#3

Sure. Here you go

Default Shield Settings

Shield Address Bar

Address Secure Lock Icon

#4

Did you try changing the Global Shields to “Allow” for each setting?

#5

What you mean? the shields are fully down (see screenshots) … i.e “Allow everything” (don’t block anything) right?

Whatever it is in brave that is disabling these menus, I’d have to switch fully to a different browser whilst working with Azure … which is super annoying as I have to switch back and forth between these two browsers for bookmarks and extensions (in brave)

Also, as I have given you all the details, including screenshots … can you not reproduce this on your end?

P.S.: No rush on this one, you can get back to me after the Holidays.

Happy Holidays

#6

When you click on the Shields panel, do you see at the bottom where it reads “Global shields defaults”?
image
Click that - it will reveal your Global/default Shields settings. Short breakdown:
Shields panel: This guy :point_down: :handles protections on a site-based level, meaning that the Shields [panel] settings

you set for any domain are for that site alone.
Global Shields: :point_down: These boys
control what Shields the panel will default to when you visit a site for the first time.

We’ve had issues with changes to the Global settings not being reflected when browsing and I’m wondering if that might be happening to you here.

#7

Bingo! that did it … I chose Allow all cookies in Global Shield Settings and now the menus are enabled.
Hmm … I find this behavior a little counter-intuitive though - If I set my Global defaults to Deny all (cookies) and then on a site-level I select allow all cookies then from what you are saying the Global would still override my site-level settings and block cookies isn’t it? Seems like that’s what it did in this case … Is this the issue with changes to Global settings you are referring to?

Anyways, I’m happy with the work around and now that I don’t have to switch browsers … this is OK for now but I hope it gets fixed soon … cause I don’t want to allow other sites to store cookies … now my default shields are down (cookie wise).

Please let me know, if you do know, an approximate ETA in days/months so that I can keep an eye out for this fix and turn those shields back up. Thanks!


#8

Glad that did the trick!
And yes, that is the shields issue I’m referring to. You can track it here:

It’s intended to be that site-level shields override globals. All sites start with whatever your global settings are and will remain that way unless changed.

#9

Awesome! Thanks again @Mattches!. You guys @ brave rock!

Happy 2019 to you!! (in advance)

Cheers

closed #10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.