"Did Not Connect: Potential Security Issue" continually in Firefox

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
I prefer to use Firefox browser. I use Brave Search as my main search. I like brave and I want to support it this way. Last two weeks I have been receiving this error. I get it every day. Firefox cannot connect to https://search.brave.com/. Sometime later it will connect. That can be five minutes to two hours till brave search will work. Sometimes this will happen in Chrome and MS Edge. But not very often. This is very annoying. I would like to keep brave search as my main search provider but this slows me down.
I would post a screenshot to see it but I see no way of doing this. Below is the exact text of the error message page:
“Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to search.brave.com because this website requires a secure connection.

What can you do about it?

search.brave.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it. You can notify the website’s administrator about the problem.

Learn more…”

Brave Version (check About Brave):
I use Firefox
Operating System: Windows 10 Pro 21H2 19044.1645

I figured out how to post an image:

Hi and welcome to the community. :slightly_smiling_face:

I can’t help you with your issue, just wanted to let you know I can open search.brave.com (https://search.brave.com) in Firefox with no issues: I do not receive that message.

I am on the same OS as you. I do not have Brave Search as my default search engine in Firefox (not offered). I do have Brave Browser set as default in Windows.

Brave 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)
Revision ff0d0695743e65305d7194f9bd309e5e1c824aa0-refs/branch-heads/4896_88@{#4}
OS Windows 10 Version 21H1 (Build 19043.1645)

I used this to add Brave search:

Do you think this is the problem? I also have Brave search as my homepage and firefox startup.

@metallurgyvariance Could be. I don’t use extensions at all so maybe an extension is causing a problem. You should try disabling (and any other extensions you have) and see if you still get the error. Also try clearing history/cache, exiting Firefox, and opening. Solves a lot of user problems here, may work there too!

Thank you, Chocoholic, for your kind help. I never thought of experimenting with disabling some or all extensions. This has not happened since I first posted here. When it happens again, I will experiment with that. Then I will post back any results.
I obsessively clear history. That should prevent old history/cache problems. Thank you for your help.

1 Like

Weird, but I am glad it is working as intended now! You should mark your above post as the solution so that community members and moderators know that, at this time, you no longer have an issue. Unless you just want to leave it open for a while “just in case”. :smiley:

1 Like

This problem has not repeated yet. It was happening quite frequent. Two or more times at least every other day. If I mark as solution, can I change it if it happens again? Or mark as solution and if it happens again, I can create a new post and link to this page. What do you recommend?
Perhaps someone at Brave saw this post and found some irregularity with the certificate or something similar. Then corrected it. And not telling anyone or posting it here. So, we really cannot know. This is what I suspect because it would have happened again by now.

1 Like

@metallurgyvariance Well, Brave does sometimes fix things in what I call stealth mode, or at least I think they do! lol Especially back-end work.

As for your topic, you can mark it as solved and then unmark it later. That works.

Be aware that the topic will auto-close after 30 days if no new posts. If that happens, you can create a new topic, copy/paste the template, and link to this one for reference.

Hope everything continues to run smoothly! Take care. :smiley:

1 Like

@metallurgyvariance , @Chocoholic ,

Along with a surge of situations wherein a user has to:

  • reload a web page in order for it to display properly

  • copy and paste the URL address for a web page, into a new window (instead of clicking on a link and expecting prior new window behavior)

  • sometimes save the URL address in a text file, then Exit/Quit the Internet browser, then start up the Internet browser and copy and paste the URL address into a new window

There are also a lot of new developments in website security and websites in general. Such as, the Brave Search Engine (beta):

1 Like

You gave three things to do when I have this problem with Brave search in Firefox. I did all the things you suggested and more when the problem happened. The problem has not repeated since I first posted this. I think someone at Brave fixed it.

It just did it again. I discovered it 10-15 minutes ago. I opened Brave search in MS Edge as soon as I discovered it in Firefox again. The problem happened in MS Edge at the time. Now Brave search works in MS Edge but not in Firefox. I just now tried it again and Brave search now works in both MS Edge and Firefox. So, I estimate Brave search was disrupted about 5 minutes in MS Edge and 15 minutes in Firefox.
I once again did exactly what 289wk said to do with Brave search in Firefox. All three things had no effect. Brave search corrected itself on its own.

I have no idea and since it is random, not sure if the moderators can help either. I couldn’t find a Brave GitHub issue report per this either. Tagging @Mattches @steeven maybe they can take a look and provide more information.

I do not know why Firefox would even have an issue since it can be set to require https:// connections too. Same feature flavor as far as I’m concerned, but what do I know. lol

Just curious, what is your Firefox settings (example image below) in Firefox about:preferences#privacy?

I’m not seeing this issue in FF on any OS — visiting search.brave.com works as intended for me in FF, MS Edge, and Chrome without any issue. To be clear, this issue in FF is occurring when you visit the site and perform a search right? Or is this just when you use the extension?

I opened up MS Edge and it just happened in Edge. 05:20pm or 05:21pm Central Time USA Friday, April 22, 2022. I did not have Firefox open at the time. I hit refresh twice. No change. Then I did one of the suggestions from 289wk. I copied and pasted Brave search address in a new tab. That worked. Brave search connected and functioned normally in MS Edge. I immediately opened Firefox. Brave search functioned normally in Firefox. I do not believe my copied and pasted Brave search address in a new MS Edge tab is the cause of Brave search to function normally. I believe Brave search corrected for some other reason. I only did some very minor personalizing changes MS Edge when I started using it. No added extensions. I like to keep MS Edge as default as I can. As in my earlier post above this happened in MS Edge before. Just that this disconnects problem lasts a very short time. I believe I can conclude it is not the Brave search extension that is the cause.
One good thing the problem does not last as long. Last week it would last for hours. Now the disconnect seemed to only last one to three minutes. And the disconnect is comparatively infrequent.

@Mattches , @metallurgyvariance , @Chocoholic ,

I just work around such a problem, but I also look at (for example):


and wonder why website authors let possible errors slip by. Granted, the W3C Validator is not perfect – and they welcome corrections.

Thank you Chocoholic for your continued interest in this. This is how I have the setting:
HTTPS-Only Mode is set “Don’t enable HTTPS-Only Mode”.
I believe the problem is independent of the extension because I have “Homepage and new windows” set to open https://search.brave.com/. Brave search is the first thing I see when I start Firefox. The extension just adds Brave search to the list of search engines in about:preferences#search. I like the Firefox search box. Because of the extension Brave search shows up in the search engine list. I then set Brave search as the default or first search just like I could with any other search engine in the list.

1 Like

Mattches, thank you for your interest in this. I think my post to Chocoholic covers your question. If not please respond and I will answer any question you have.

Awwww, you are welcome. That was nice!

I’ll keep tracking because I’m curious to see if the problem can be identified but I’m leaving it to the experts now. Nothing I can add! lol

289wk, thank you your continued interest in this. My post to Chocoholic I think establishes that I do not believe it is the extension causing this disconnect problem. I will work around the problem because I like Brave and want to support this search engine being independent. And it is shorter disconnect when it happens and it is now quite infrequent.
I am not familiar with validators. 289wk, if you need me to do something to help this let me know.
I am continuing with this in hopes Brave will figure out what the problem is.

This problem has not happened for a long time. I use Brave search many times a day using Firefox. I think your “stealth mode” theory is the solution. Because I did not do anything different. I am marking this as the solution. Thank you all who contributed to this discussion.

1 Like