Delayed response to keystrokes submitting security characters

Description of the issue:
VERY delayed recognition of keystrokes submitting security details to the United Kingdom’s largest bank (Natwest / Royal Bank of Scotland)

How can this issue be reproduced?

1.If required, obtain valid “developer test credentials” from Natwest / RBS
2. Ensure you have valid login details for either of the relevant bank which are part of the same group and appear to use the same web code and certainly demonstrate the same behaviour.
3. When asked to enter the 6 security digits and characters, enter them, 1,2,3,4,5 or all 6 (ie using the keyboard buffer).

Actual result
They do appear - EVENTUALLY! It can take many, many seconds before they appear! “Wait” popup boxes usually appear, though not always. I click wait, of course

Expected result:
Instant response by the bank to each character as the keyboard stroke entry is made.

Reproducable how often
Always (on Brave, but NEVER on either Edge or Chrome)

Brave Version( check About Brave):
“Up to date” (Brave 1.45.133)

Additional Information:
I am using
Windows 10 Pro Version 22H2
OS build 19045.2251
Experience Windows Feature Experience Pack 120.2212.4170.0

I have tried this on several other windows devices I have, with the same problem manifesting itself on all of them

I have 78 MB/s fibre broadband

I have 4 decades of experience as a software developer and computer engineer and am only submitting this annoying problem after several updates of Brave have failed to fix the issue.

1 Like

Hello there @david9 please accept my apologies for this issue. Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let me know if that works.

Thanks for the reply.

Please read through to the “new story” that has become apparent and the VERY EASY way that anyone, anywhere, should be able to replicate my experience, or not, in fewer than 10 or so seconds

Although I don’t see "“Additional Settings” in the current Windows version of Brave, presumably you are referring to “Use hardware acceleration when available” in “System”. If so, it seemed to already be enabled. However, whilst writing this reply, oddly a message telling me to relaunch Brave appeared right over that option, so I did.

The result was a disappointing surprise. The FIRST security character I entered DID appear instantly, but then the remaining 5 seemed to sit in the keyboard buffer as before.

As there seemed to have been a partial success, I closed and relaunched Brave (again) but the reported delay was exactly as before. All 6 characters sit in a keyboard buffer for many seconds (33 seconds, this time, per my stopwatch) before the asterisks all appear in the blink of an eye.

FURTHER INFO. Having retried many times I notice that although the cursor appears in the box for the first character for about a second, it then disappears. Whilst staring at that behaviour and NOT entering the requested security characters up popped Page unresponsive.

So, the reported issue of keyboard delay may not be the issue at all. If I wasn;t a geek or was a bright young thing I might sometimes delay entering the requested characters and have seen that message, but I would always be typing int the characters very quickly.

You can reproduce what I am doing VERY easily. – Login

It is no secret that the Natwest / Royal bank of Scotland “Customer Number” consists of date of birth followed by a 4 digit number

e.g. 01041980500 (April Fool’s day in "the year MSDOS / Windows dates started)_
and click the “Continue” button, which should launch the security page, where the cursor / page unresponsive behaviour I describe is seen (on my computers here).


1 Like


Hi again David, could you please try opening your main profile in private or guest mode to see if the issue persist? If it does not, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Thanks for suggestions.

Open guest window - same behaviour.

Extensions. Went to remove the ONE extension (Adblock Plus) I thought I’d installed but found I wasn’t using it on Brave. The Manage Extensions shows I have none. I have no added extensions. I even disabled Hangouts and Widevine, not that I installed them. No difference. Cursor disappears, page unresponsive message appears.

Have you tried the 10 second test for yourself? Number=010480500-Continue button. wait a second or 2 and the cursor on the 1st security number box disappears and no data entry keystroke will return a response (*) for many, many seconds, although it does / they do get buffered. Obviously, there’s no point entering anything since 0104800500 is either a customer number that is not in use, or somebody else’s! There is no need to type anything, just watch the cursor appear, disappear and eventually reappear on the 1st data entry box.

It takes just seconds for anyone to see the problem, assuming the problem manifests itself on your Brave browser.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.