Default zoom setting ignored

Win 11
[
Version 1.64.113 Chromium: 123.0.6312.86 (Official Build) (64-bit)
]
I’ve set the default zoom to 67% but most pages open at 100% some at 90%.
Removed zoom extension – no change

This, coupled with inability to customize toolbar (like firefox) and the fact that I can’t reorder the extensions in the dropdown means that

I’m going to have to use a different browser until these things are fixed. As it stands it’s simply to clumsy and inefficient to use as my primary browser.

I thought that someone might care to address these things before they work on all those thing that clog the home page (and which I immediately disabled).

And, btw, Brave’s spell ckecker is totally lame. type “thay” it doesn’t offer they as one of the option :frowning:

Can you try testing this in a fresh profile and tell me if you get the same results? I’m wondering if the zoom (I’m assuming you mean an extension that assists with the zoom functionality, not the actual “Zoom” extension) extension you used left some weird data in your profile which is causing the odd behavior. I just tested this on my Win 10 and macOS system and am getting consistent results.