Default location behavior not working?

Description of the issue:

In Settings > Privacy & Security > Location, “Default behavior” is set to “Don’t allow sites to see your location.” There are no sides added under “Customized behaviors.” However I still see the location permissions popup whenever I visit any site that requests my location.

How can this issue be reproduced?

  1. Set location default location behavior to “Don’t allow sites to see your location.”
  2. Visit any web site that wants my location.
  3. Observe popup requesting location.

Expected result:

No popup requesting location.

Brave Version( check About Brave):

Version 1.59.117 Chromium: 118.0.5993.70 (Official Build) (64-bit) on Ubuntu 22.04.3 LTS

Additional Information:

Added screenshots below of my location settings and the location popup I keep seeing:

Location Popup

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.