Default google search tab is google.com.hk, in hong kong. Neither my location nor my ip is in hk

As title says, I’m using a vpn to tunnel out of Indonesia. Chrome, fire fox, and opera would take me to google.com. brave is persistently changing my google.com to google.com/hk. The standard search tab preferences only offer google.com/hk.

My language setting is English uk and English.

Would love some help manually changing the default search tab to Google.com and not google.com/hk

Hi @Eaedyan

This isn’t what you see when you go to about:preferences#search - you see an entry for google hk?

I’m not sure how it changed to normal, i had the problem literally 2 hours before you posted. As soon as you did the problem resolved itself.

The image for default search tabs is different and i can’t upload pictures from my phone.

On mine the choices included the webmoo link as well
On that page google was listed as google,com/hk

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.