Default e-mail client - Help!

Description of the issue: When I click an e-mail icon, it goes to an old account with Microsoft exchange, I’ve deleted everywhere else on my system. I am trying to set it to use the Apple default, but it keeps going to exchange. Any tips, please?

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Directly to the incorrect e-mail client, single click

Actual Result (gifs and screenshots are welcome!):

Expected result:
I have tried changing everything on my system to default to the Apple mail client.

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:
Screenshot 2023-09-13 at 11.20.59 AM

Can you please go to brave://settings/handlers and see if you have anything listed here as your default handler? If so, please remove it as a handler, then try clicking the email link again.

Thank you, so so much. I can’t believe how hard that was to find!

1 Like