Default Browser Settings

Brave is my default browser, but Microsoft Outlook still pulls up Edge when I click on a message link.

I cannot find anywhere to delink Edge from being Outlook’s browser of choice.

@Bob1,
In Outlook, go to File --> Options --> Advanced and scroll down to Link Handling and change the option here from Edge to Default browser.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.