Dark mode inconsistency bug, likely unintended but sloppy, cosmetic mishap

Selecting “Brave Settings” in the top-right dropdown menu opens the settings page as a new tab.

This page is in itself a set of tabs, displayed horizontally across the top. The first is “Settings”.

In the “Appearance” section a little down the page you can select Brave colors in a dropdown, choices are “same as windows”, “dark” and “light”.

Selecting for example “dark” (my preference, easier on the eyes in a dimmed-light office) sets all the horizontal tabs (Settings | Brave Rewards | History | Bookmarks | Downloads | Crypto Wallets) to the chosen theme EXCEPT Brave Rewards which remains bright or unchanged.

This is inconsistent and seems like a slight and sloppy cosmetic mishap, which is a shame for such an otherwise great piece of software that Brave is. Small detail, easy fix :slight_smile:

1 Like

Hmmm. Don’t have that on my installs:
Brave Nightly and Brave Dev on openSuse Tumbleweed.
See my screenshot for the coloration of my “Brave menu”

Maybe it’s a “Windows thing”?
(I assume you’re running Windows because you wrote …choices are “same as windows”, “dark” and “light”) … I don’t have the “same as windows” option.

Can you share a screenshot of the behavior you’re seeing?

i have the same one

if i got you right

@Mattches i think he mean that he set the color option in the apperance to dark but the reward setting page is not dark and it light

dark settings

but light on the reward page

and i have the same experience here i am on linux centos 8.2

i tested to create new profile and it’s the same

and have a nice day everyone

@soren.fog @justsomeone1 an open issue here

thanks @eljuno hope they make it soon and have a nice day :slight_smile:


My Rewards page (Brave Nightly and Brave Dev on openSuse Linux) is not like that, but in Dark mode

looks like they will release it soon i am using the release version

thanks for let us know about that and have a nice day

@caldercay if you have “Dark web content” enabled via flag, then it’ll shown in dark mode.

While the issue above, the page should in dark mode when Brave Colors’s set to “Dark”.

Yea, I have both set enabled.

Sorry for delayed answer, but sure, here you go.
And I think another question was if I use Windows, yes, I do, Windows 10.

This is a known issue that is unfortunately still not addressed. Seems to have been logged a while ago – I’ve added your report to the thread for the devs to see and will try to make some noise about this as well:


I assume all those pages are rendered as dark mode for me because I have this enabled

That is correct – the flag forces dark mode but it’s not “themed” in the same way the browser is, if that makes sense.