Cycle through windows on Mac

This is my first posting in this forum - I hope I’m doing it correctly.
I’m using Brave as my preferred browser since about 6 months and I’m very happy with it.

With one of the latest Brave updates I’m having the issue that my keyboard shortcut to cyle between Brave Windows has changed.
I have a system wide configuration on my Mac to use the shortcurt CMD + < on my Swiss Keyboard layout (I think this corresponds to CMD + ` on a US keyboard) to move the focus to the next window of the same application. This has always worked fine for all Apps including Brave. But with the latest version of Brave I’d have to use the shortcut CMD + SHIFT + < for Brave which is kind of annoying. (CMD + < now opens the Brave settings brave://settings/)

Can I configure this shortcut for Brave somewhere?

Thanks for any help

[Version 1.57.47 Chromium: 116.0.5845.96 (Official Build) (arm64) on MacOS 13.5 (22G74)]

1 Like

All shortcuts can be modified at

Also, you can check at

I got the exact same problem (Swiss keyboard as well).

@SmartyAadi unfortunately that didn’t help. The settings shortcut is already set to ⌘ + , (see screenshot) but it still also reacts to ⌘ + <

@goll did you find a solution?

Thank you @SmartyAadi, but unfortunately it didn’t work for me either.

Brave is my default browser for years and I’ve been using the shortcut ‘command’ + $ and ‘command’ + ‘shift’ + $ to cycle back forth between Brave windows, with a French keyboard an a Macbook Air.

Since a recent update, I can use the shortcut to go to the next window, but I’m no longer able to go back to the previous one. It still works well on Chrome.

I checked your settings links, but there’s no visible shortcuts for cycling through pages, and searching for ‘cycle’ only shows an option for cycling through tabs, not windows.

@goll lulezi did you find a solution?
I’d hate to have to switch to another browser :frowning:

@philh @lulezi @goll @SmartyAadi

Answer is at Switching between windows on MacOS - #3 by Mattches

Though can summarize here so you don’t have to click.

It’s a known issue being worked on. Github is

Until official fix lands, which will occur around 1.58 (should see in next week or two), you will need to do the below

  1. Launch Brave, go to brave://flags
  2. Search for a flag called #brave-comands
  3. Set the value to Disabled and relaunch the browser

Once 1.58 hits, you can readjust the flag so you’ll be able to do custom shortcuts if you’d like.


Amazing!!! It worked perfectly.

Thank you so much! :pray::pray::pray:

Excellent - that works indeed.
Thanks you very much Saoiray!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.