Cut and Paste doesn't work!

The system informed me that this issue has already been reported. It seems like a basic function that should have been obvious. Note that my workaround is to use a different browser!

What system?

Just so you know, cut and paste is usually something within your operating system and not the browser. The exception to the rule is if you’re visiting a website that has it disabled. Are you experiencing this issue only on particular sites or what’s happening?

Passive aggressive response: Threatening doesn’t help you. If you want to go elsewhere, you can. But if you’re here just to ask for help, then please just ask and be nice about it. Everyone always knows you have the option to leave or use something else. Saying it does not encourage anyone to want to help you but instead can do the opposite.

Really need you to fill out some more details.

  • What operating system are you using?

  • What version of Brave are you using? (give number, don’t just say “the latest”)

  • Give a detailed description of the issue: (what are you trying to cut/paste? How are you trying to do it? What happens when you try? And anything else that might be important)

Sorry for the attitude. Grouchy.
Thanks for the timely reply.

The System = Brave Community forum responses.
Using Brave version 1.41.100 Chromium: 103.0.5060.134(Official Build) (64-bit)
OS = Kubuntu 20.04
Cut and paste does not work on any website.

Regards,

Ken

All good, I was kind of the same way. Otherwise I’d have not done the little passive aggressive thing. We all have our moments.

I honestly know nothing about Kubuntu. So I’ll tag @JimB1 as they seem to be extremely knowledgeable on things here.

This probably is going to be absolutely no help, but when I was trying to search for anything similar, I came across link below. Guessing it’s something completely different and irrelevant, but just in case it has a clue in it…

Anything else I found related was Ubuntu, so I’m not sure if that would have been helpful. Again, I know NOTHING about Linux, such as Kubuntu, Ubuntu, or whatever else.

Hopefully JimB1, @289wk, or even @Chocoholic may have perfect thoughts for you. If not, will hope maybe @Mattches drops in tomorrow and has good info.

Thanks for understanding, Saolray. There are several different GUIs available for linux distros. ubuntu uses Gnome and the KDE group replaces that with KDE. So, KDE is just a variety of ubuntu.
BTW, I just tried Brave on my wife’s Windows 10 (not 11) and the cut and paste works perfectly.

Blessings,

Ken

Yeah, I’ve not seen many people speaking of it as an issue. I use Brave on Windows, iPhone, and Android. I was trying to go through as best I can to figure things out, but it’s an odd situation. Of course, out of everyone who helps here on Brave Community, I’m the least knowledgeable overall. My assistance is primarily just through communication with others and kind of compiling info. So as solutions have been worked through for others, I essentially learn what happened and share it around.

Hopefully one of the others will have some good suggestions and/or the solution for you on why yours isn’t allowing.

Hmm this issue sounds familiar for some reason, I’ll see if I can dig up a similar thread, I feel like this came up maybe 6 months or so ago.

(Nevermind, I was thinking of this, but seems irrelevant: Paste/undo bug in Brave Browser)

In the meantime @kenj74,

Were you provided any links to previous threads or issue reports that we could look at?

This Reddit thread is a little older, but does any of it look similar to what you’re seeing? https://www.reddit.com/r/kde/comments/oxww24/kde_copy_paste_still_broken/

Also, you mentioned cut and paste, but does the issue also affect copy?

Is it only when you try pasting back into Brave, or does pasting into another app (such as a text editor) work?

What if you copy from a text editor, then try to paste into Brave?

Is it only an issue using keyboard shortcuts, or do the right-click Cut/Copy/Paste work?

What website and form field are you testing with (any 1 example should do)?

In what browsers does it work? Firefox? Chromium? Chrome?

Hi JimB1. Time for more detail.

I first searched for cut and paste problems and found several hits. IIRC, they looked somewhat old so I decided to start a new topic thread.

In Firefox I can click somewhere in a paragraph of text and the cursor will appear. Holding down the left mouse button and sliding the mouse I can highlight a portion of text. In Chromium I can click somewhere in a paragraph of text but cursor will not appear. However, I can slide the mouse to highlight a portion of text. In Firefox and Chromium I can left-click in the highlighted text and a dialog box appears, giving Cut and so-on. In Brave neither the cursor nor the highlight appear so a dialog box never appears! So, cutting from Brave is not an option. Trying to paste from another application the dialog box does not appear, so it’s not possible. As mentioned before, since no cursor appears I cannot use Ctrl-V to paste either.

HTH, Ken.