Crypto Wallet: Trezor Connect out of date

Description of the issue:
When using a Trezor-backed wallet in the Crypto Wallets tool, every time I have to do something on the Trezor device, I get a warning window saying the following:
"The current version of firmware (2.3.4) may be not compatible with the running version of Trezor Connect. "

While everything is functioning fine so far, since crypto stuff is tech-sensitive, just wanted to let you guys know you should upgrade the version of Trezor Connect middleware you embed in Brave. Thanks!

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Set up a wallet in the Crypto Wallets tool backed by a Trezor device
  2. Make sure Trezor device firmware is up to date
  3. Try to do any crypto transcation (e.g. sign a message through Metamask)

Actual Result (gifs and screenshots are welcome!):

Expected result:
Trezor does not complain about Trezor Connect version mismatch.

Reproduces how often:
Every time I do an action that requires interaction with Trezor

Operating System and Brave Version(See the About Brave page in the main menu):
Windows build 19041
Brave Dev 1.16.63

Additional Information: