Couldn't change password on Mailerlite


This is the issue as of 03-25-20, but I had the issue a week prior to that as well.

I wasted my time contacting the company & they told me they have no other reports that this is an issue.

AND I even turned off the shield & I still had the issue. is the site. I went to go change the p/w inside after being logged in & the button wouldn’t click.

So they told me to change it thru the “forget p/w” link. I did that & entered in the new p/w & up popped a window where you have to insert the old p/w & then the new one. This is the same popup that showed up when I tried to change the p/w inside the account the week before & again the “change p/w” button wouldn’t work.

I did this on Chrome & it worked PERFECTLY & no extra popup.

And this was on 2 different accounts (same site) that this happened, as I have 2 different accounts.


Hi @OurFreeSociety,
Would you be willing to change your password again to see if we can diagnose the issue. If so, can you go back to the mailerlite site and set your settings in the Shields panel to all cookies allowed and let us know if it goes through.
e.g. here a picture of the panel.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.