CORS Error on multiple sites

Description of the issue:
CORS Errors on multiple sites including gmail, google Calendar, JIRA and others.
Steps to Reproduce (add as many as necessary): 1. 2. 3.
Start brave
navigate to site
view counsel.
Actual Result (gifs and screenshots are welcome!):
Access to font at ‘’ from origin ‘’ has been blocked by CORS policy: Request header field pragma is not allowed by Access-Control-Allow-Headers in preflight response.
KFOlCnqEu92Fr1MmWUlfBBc4AMP6lQ.woff2:1 Failed to load resource: net::ERR_FAILED

Expected result:
No CORS errors and the site works.
Reproduces how often:
Consistently on my system (though others I know don’t have the same problem.)
Operating System and Brave Version(See the About Brave page in the main menu):
Additional Information:
I’ve tried with Shields up and down.
Different security settings.
Sites always have the problem.
Other sites like, stackoverflow, don’t have the errors.

When I visit the site you linked to it prompts me to download the font (also using macOS w/Big Sur). Where exactly are you seeing these console message appear?

Thanks. I inspect the page then go to Console and I see the errors.
I don’t remember ever seeing a prompt to download a font. Is there a setting that blocks stuff like that?

What page are you inspecting? This one: Because that is a direct link to download that font.

I’m inspecting the google calendar main page:

And then what do you do to produce the CORS errors you’re seeing? The Console on the calendar itself for me shows nothing:

Nothing they are just there. I know a few other users of Brave and they don’t have the problem. Can’t figure out what is wrong with my setup.

Posted here wondering if anyone else had the problem, or get ideas of what could be causing the error only on one computer. To my knowledge nothing on a specific machine should cause CORS errors.

Do you have browser extensions installed at this time? Additionally, can you try creating a temp. new browser profile and see if you get the same results there?


Thank you for the suggestions. I tried a private window and it worked as desired. Disabled and enabled the plugins one at a time. Looks like
was causing an error. Thank you for all the help.

1 Like

You’re very welcome – glad we were able to resolve that.

1 Like