Copy/paste your Wallet ID (found on brave://rewards-internals ) Your OS and Brave version (first three lines in brave://version ) A screenshot of your Rewards panel in Settings --> Brave Rewards

I still have not received my rewards from my laptop, yet it says payments are complete.

Continuing the discussion from Brave rewards not received for January:

Please ensure that you’ve read through the following topics/pages thoroughly before opening a topic as your question may have already been answered:

Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Briefly describe your issue:

What Operating System and Brave version are you using (Menu --> About Brave)?

Is your browser wallet currently verified? (yes/no)

What date did you verify your wallet?

Have you been able to successfully receive payments in the past?

Are you using a VPN? (yes/no)

Are you in a supported region (see here for list of supported regions)?

Does your device pass the SafteyNet check (Android only)?

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

Thank you for reporting! Please DM with the following information:

  • Copy/paste your Wallet ID (found on brave://rewards-internals)
  • Your OS and Brave version (first three lines in brave://version)
  • A screenshot of your Rewards panel in Settings --> Brave Rewards.

This will help to speed up the troubleshooting. Thank you in advance!