Cookie Settings Bug

There is a bug in the shield settings of Brave for Android, which causes changes to the cookie settings to be ineffective, automatically reverting them to ‘allow all cookies.’

A potential workaround involves navigating to site settings and selecting the option to block third-party cookies. However, a noteworthy issue persists: when users revisit the shield settings and simply click “done” without making any modifications, the setting reverts back to ‘allow all cookies’ without requiring any additional user input.

This problem has been a point of concern for numerous users on Brave’s subreddit for several months. Below are links to some of these discussions.

@user07 it’s just a visual glitch. I just tested on my Android (and could upload a video if necessary). You’re right that if you go to Allow all cookies and then go to switch to Block cross-site cookies that the menu appears to switch back automatically to Allow all cookies. But when I hit back on the menu and then clicked on Brave Shields & Privacy again, it loaded with my setting at Block cross-site cookies just as I had selected.

Would you check this yourself?

@Saoiray That too is a visual glitch; it just shows that cross-site cookies are blocked after exiting and reopening, but in reality, they aren’t. You can verify it by visiting any website and then tapping the Brave Shield icon or by going to Settings → Site Settings → Cookies; you’d find that all cookies are allowed. I’ve already tested it thoroughly before posting here.

Also, in the first attached reddit link, a user has already mentioned doing it, and you can find the OP’s response here.

@user07 okay, so just tested and it does seem like they don’t adjust each other necessarily. But if you change both to third party only, then it remains that setting. I’m going to look to see if there’s an open Github on this by chance. If not, I’ll make one.

It looks like there’s an open Github on this over as shown below:

I’m going to tag @Mattches on this as well for awareness. I’ll go ahead and add a +1 and some information over on that as well.

Yes, but you don’t need to change both; it can be done by going into Settings → Site Settings → Cookies and selecting ‘Block Third-Party Cookies’.

However, one thing to keep in mind and is another major bug too, which occurs without any user input:

You can check on yours @Saoiray

Yeah, I checked that. It still is the behavior I mentioned earlier. It will show as if it switched to Allow all cookies but if you click back and then enter the menu again, it will show Block cross-site cookies. At least is how it worked when I tried it.

Yes, if I click on it and it opens the choices, then I tap anywhere else or choose an option, it will show Allow all cookies. But again, if I click < and enter Brave Shields & privacy again, it will show Block cross-site cookies as my selection (assuming I had last tapped on that)

But that would be just a false positive, which can be verified by going into site settings.

What I actually meant to say is that when a user installs Brave on Android and doesn’t change any cookie settings in the Shields settings, they simply tap to view the default cookie settings applied, and then tap back or done. Here, it reverts to ‘Allow all cookies’ by itself without any user input. Even if someone like us, who knows about the bug and the workaround for cookies that can only be done via site settings, goes into the Shield settings, taps on cookies, doesn’t input anything, and taps the ‘Done’ button, understanding what has been applied will still be that way. Boom! Once again, it has changed to ‘Allow all cookies’ without any user input.

@user07 I guess let me show you what I am seeing on testing.

You’re exactly seeing what is actually the bug and is same here. I don’t understand why it became confusing even though I’ve kept everything clear since the beginning. As I’ve seen in our conversation and in your video too, you emphasized closing and reopening shield settings more, but that isn’t the concern, and it doesn’t fix anything. I’ve already addressed this here:

The real matter is that if anyone has even touched the cookies in shield settings and didn’t choose any options, the browser-level cookie settings revert to allowing all cookies.

Same issue here

Didn’t know that there’s a workaround for it, thanks. I thought I must have messed up something during setup. :sweat_smile: And will keep in mind to not tap cookies in shield settings after applying workaround until this gets fixed. Saw those reddit posts too, this has been floating around for months and hasn’t been fixed yet. Anyways, I’ll wait until the brave team gets this fixed soon, and I hope it won’t take months for such a serious bug.

1 Like

I’m hopeful, but my optimism is waning as I’ve come across numerous reddit posts, comments, and gitHub issues that have persisted for months without any indication of a resolution in sight.

One of the comments from attached link:

Hey @Mattches, sorry for the tag; I just wanted to have your attention on this. This is a major bug that has been there for months, affecting almost all devices running brave on android.

@callidae I just want to make sure you noticed I shared an open Github issue for it. If you click and read through, you’ll see someone assigned it to themselves in July. This means it’s a project in motion.

@Saoiray Yes, I’ve already seen that. I’ve tagged @Mattches here just to ensure he’s aware of it and can prioritize it if necessary.

1 Like

I’ve pinged some team members internally as well as in the thread to hopefully get more eyes on this.

Thank you

1 Like

Just to thank you, I’m not a developer but I appreciate the workaround.

1 Like

Thanks a lot! @Mattches

Looks like we got some movement on the issue — priority and status of the issue has been updated :+1:

1 Like

Yeah, hoping it’ll finally be fixed and won’t take any longer.