Cookie popup on websites keeps appearing on https://www.telegraaf.nl

Description of the issue:
Opening newswebsite http://www.telegraaf.nl give a cookies pop up. When clicking on ‘accept’ the pop up reappears. Again and again.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open the url https://www.telegraaf.nl
  2. A message about cookies pops up. The url opened at that time is https://tmgonlinemedia.nl/consent/consent/?return=https%3A%2F%2Fwww.telegraaf.nl%2F&clienttime=1563221616530&version=5&guid=66b486c3-d31e-87c6-f434-89d268a486a5
  3. When accepting the cookies the address bar gets back to the main site (as mentioned in step 1) however immediately results in the cookies pop up from the website again.

Actual Result (gifs and screenshots are welcome!):
Reappearence of the cookie pop up
telegraaf-cookies-brave-browser

Expected result:
No pop up, just the website

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 rs_prerelease, Versie 0.66.99 Chromium: 75.0.3770.100 (Officiële build) (64-bits)
Additional Information:

It looks like you are blocking all cookies. If you change the shield setting to 3rd-party cookies blocked you can use the site normally.

Usually those cookie notifications aren’t that aggressive, but it seems that they really want you to accept them :smiley:

If you don’t accept any cookies, the website has no way of remembering you. Therefore it will treat you as a new user every time, showing you this notification.

If you change the shield settings on this website, the setting will only be applied to this specific website.

1 Like

@BigDaddy in addition to @Medjan, you can change the cookies setting via Brave icon at URL bar. It’s per site shield settings and will not affect other sites.

The actual cookie message can be blocked via adblock tools, but whether it should be by the default filters is another story. When the adblock engine improves to support cosmetic filtering, I’l request a cookie/gdpr filterset to be included as an optional list.

Hi Medjan,

I only block 3rd party cookies and only when allowing all cookies the pop up doesn’t appear anymore. Thanks for your reply.

Hi Eljuno,

I tried changing the cookie setting via the Brave icon on the URL bar and put it on ‘allow all cookies’ but that doesn’t help. Only allowing all cookies in global settings seems to fix the issue for now. Thanks for your reply.

I think the problem here is that I should be able to allow cookies on www.telegraaf.nl however once the popup is on screen the website url shows tmgonlinemedia.nl. Allowing cookies for this website doesn’t solve the problem.

Is your default shield setting not to accept any cookies? The first time I tried this, I didn’t have any problems. Now i cleared all cookies and then had the same problem you have, because for testing reasons I set the shield to blocked all cookies on telegraaf.nl.

telegraaf.nl redirects you directly to tmgonlinemedia.nl, because they handle the cookies. Even if you set the shields to allow cookies there, as soon as you click the green button you will get back to telegraaf.nl, where the default shields still apply. They don’t see any cookies and send you back to tmgonlinemedia.nl.
To break that cycle you could set the default settings to allow all cookies for a moment. Then, after being redirected to tmgonlinemedia.nl, set the shield to block 3rd-party only. You should be able to visit telegraaf.nl now. Set the same shield setting there. Now you can go back reset the global shield settings.
Does this work for you?

(If this didn’t work: In case at some point blocked all cookies specifically for telegraaf.nl, you need to delete that setting first. Go here chrome://settings/content/all, delete cookies and permissions for both of the websites.)

Hi all,

It seems some of my messages were marked as spam. I apologise for that, but in order to explain the issue I meeded to involve website links.

I hope Medjan still received my last email, as I was finally able to solve the issue with his help.