Connecting to Opensea.io

I can’t connect to Opensea.io using the Brave wallet. I was able to connect using metamask. Is there setting procedure that I have to follow?

Hi @jkng0302 , happy to help you!

Please try these steps so we can rule out some things: :pray:

  1. Go to brave://settings/wallet and make sure your Default cryptocurrency wallet is set to Brave Wallet

  1. Open up your Brave Wallet Panel and make sure your Network is set to Ethereum Mainnet

Screen Shot 2022-01-05 at 7.23.48 AM

  1. Make sure you Brave Wallet is unlocked and go back to opensea.io and click the Wallet Icon at the top right of the page, then select MeteMask.

  1. You should be prompt to select an account to connect, Click Next and then Connect

  1. Should be connected now :slight_smile:

Yes. It worked. I think the key was setting the wallet to Ethereum network. Thank you very much.

2 Likes