'Confirm you're not a robot' on mobile when going back to search results

Description of the issue:
I can’t go ‘back’ to a list of browser search results without the browser seemingly hanging (you can see the loading bar gets stuck almost immediately), then it eventually gives me the ‘confirm you’re not a robot’ screen with the slider you have to drag.

How can this issue be reproduced?

  1. Search for anything in the address bar of Brave e.g. “Why does my cat bite me”
  2. Tap on any of the search results
  3. Page loads
  4. Hit ‘back’ in brave
  5. Orange loading indicator gets stuck
  6. Get annoyed and start pressing back again
  7. Presented with the ‘confirm you’re not a robot’ test

Expected result:
Able to go ‘back’ to search results without it hanging and eventually giving me the robot test.

Brave Version( check About Brave):
1.32.3 (21.11.17.19), using the Brave search engine

Mobile Device details
iPhone 12 Pro iOS 15.2

Additional Information:
Other steps taken:
Deleted the brave app, turned the phone off then reinstalled the app
Same thing happens on 4G so not network related
Checked that Brave VPN is disabled plus the one in phone settings is off
Tried mobile Safari and this bug doesn’t happen
Doesn’t happen on Brave desktop (Macbook air)
Edit
I’ve just seen the captcha test on my mac now too for the first time. Note that I’ve cycled both the modem and EERO’s, also made sure that devices on my network are up to date. I’ve virus scanned my mac.

Argh!

2 Likes

Reproduced on Brave search engine, does not happen if switched to DuckDuckGo or Google in Brave. Pretty unusable with Brave search! :-1:

I have the same issue on my iPhone. Is there anyway to get rid of it .

Thanks

I switched to using DuckDuckGo. A bit more annoying as it has ads. Considering going to safari with an additional content blocker soon.

Same issue here. Makes the browser unusable. Had high hopes but this is a massive disappointment

Wife & I have same problem. Went back to DuckDuckGo search engine, no problems.

There is a temporary work around but is still awful.

Search - Open page - Back - tap URL/Search Bar (your search text should show) - then tap go on keyboard.

Ha now when I try to get this to work It doesn’t and now being sent back brave new tab page or the browser crashes.