Compatible with mac big sir os?

Would like to upgrade my OS on my mac to BIG SIR. Would like to know if BRAVE BROWSER will work with it?

@duozen,
Yes – you will be able to update to Big Sir and still use Brave. System requirements are for macOS version 10.11.0 or later.

WOW! a reply within a resonable timeframe & sent directly to my email, AWESOME thanks, Now try getting that from GOOGLE.

Nous supportons Walka Water, SVP. DONNEZ Merci.

We Support Walka Water, Please DONATE Thank You.

Apr 27, 2021, 15:59 by brave@discoursemail.com:

1 Like

@duozen,
Happy to assist.