CMD W closes all tabs or is ignored

Mac OS 14.0 Sonoma, Brave 118.1.59.122, Apple M2 Pro Mac Mini
Often when trying to close a tab the CMD W will be completely ignored repeatedly. Other times the same input will result in all tabs and the Brave browser window closing and all sites will have to be reloaded and logged into again. As you can imagine, this is extremely irritating after a few instances. CMD W has been used so long to close the tab I’m on that I’m not about to try to retrain myself to not use it and it works as expected in other browsers and apps. I’m temporarily using Firefox now, hoping for a fix so I can return to Brave.

Description of the issue:
How can this issue be reproduced?

  1. Have several tabs open and hit CMD W

Expected result:
Tab you are on should close, and only that tab
Brave Version( check About Brave):
118.1.59.122
Additional Information:

@JustBill,
Thank you for reaching out.
I am also on macOS 14.0 Sonoma and use the cmd + w command regularly without issue. I do, however, sometimes hit cmd + q on accident, which will quit the browser which might be something to consider.

Additionally, can you go to Settings --> System --> Shortcuts and search for the close tab shortcut and ensure that it is set to cmd + w as expected?

thanks for the suggestions. I checked the shortcuts setting and they are correct for closing a tab as CMD W. My CMD W is also working as expected in Firefox, Safari and when closing other document pages and such. I think that related to this problem is that only on Brave am I having the CMD W ignored repeatedly, with nothing happening and then I close out the tab manually; other times it just closes out Brave completely. That this only is happening in Brave and only in the last few weeks seems indicative that something has changed in the one of the last updates that causes this with my particular setup.

Can you please test this in a new browser profile and see if you get the same behavior? Please ensure that you only have the one (newly created) profile window open while testing.

OK, I’ve created a new profile and will test it over the coming days.

1 Like

I’ve been using the original profile for some days now without issue and then this morning abnormal behavior came back. I can’t paste while in Brave. I was attempting to paste a url into Facebook using cmd V and nothing happened. After multiple attempts I tried from the dropdown menu and noticed that the paste function was grayed out. I went to another app, Notes, and all the edit functions were as expected. For some reasons Brave suddenly, as paste was working earlier this morning, stopped allowing me to paste anything. I then tried to close the Facebook tab using cmd W and that also wouldn’t work and I closed the tab manually. Opening a new FB tab didn’t solve the problem. I know it will probably return to normality if I reboot Brave, but this is an inconvenience as I have to log into and pin a number of tabs I use daily, only to have this problem repeat at random.

A few minutes after my last post I went back to the FB tab and was able to paste the url that just a few minutes ago would not work. There is some really strange instability going on with the browser that it stops and starts responding to the inputs at random. None of these malfunctions are occurring in any of my other apps to suggest it is an input or output problem with the bluetooth mouse, keyboard or trackpad. I have also tried the same tabs open in Safari and Firefox and haven’t experienced the issues there, only in Brave.

I just used cmd w to close a tab and it closed all the tabs in Brave and the main Brave window. I then opened Brave again and chose this tab to report this and had trouble logging in as the tab repeatedly refused to allow me to click on the sign in icon. There is definitely something wrong with my installation of Brave that periodically either completely ignores my inputs, or changes them as in the case of executing a cmd q when I input a cmd w – I know they are close together on the keyboard but this last time everything disappeared while I still had my finges on the w, there was no mistake about the letter pressed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.