Cloudflare hCaptcha and Turnstile not working

Description of the issue:
Since updating Brave, 2 updates ago, I can’t enter any website protected by Cloudflare hCaptcha and their new version, Turnstile captcha. Meanwhile, Google reCpatcha is working fine.

I have tried clearing cookies, turning shields off, solving it from multiple profiles, including incognito mode and Guest profile - same results everywhere.

Brave Version( check About Brave): [
Version 1.45.123 Chromium: 107.0.5304.110 (Official Build) (64-bit)

Additional Information:


Given there a “403” from https://captcha.website/ (going by the logs), seems to be their side.

Have visited the site now, seems okay?

I visited captcha.website just to create logs. They are identical on every cloudflare protected website which triggers captcha. It lets me solve it, but then instead of letting me in, the website refreshes and requires me to solve it again.

UPDATE: I found out what’s causing this bug. A VPN!
I tried multiple versions of openvpn, tried wireguard as well - same result.

As soon as I disconnect from VPN, solving captcha let’s me in.

This problem does not occur with Firefox or Chrome.

Environment: fresh install Brave on Fedora 37

Video:

Looks like it’s fixed now in Version 1.45.133

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.