Cloudflare CAPTCHAs not loading in Brave browser

Description of the issue:

I have been having an issue loading Cloudflare CAPTCHAs or websites that use Cloudflare protection in general for several weeks.

In most cases, I cannot load these websites when using the Brave browser with Cloudflare WARP enabled. Brave has been updated regularly since then, and there was a thread a few months ago that suggested the issue was due to fingerprinting, which was fixed, but this is not the case for me. The websites also do not load when I disable all protection in Brave, so I suspect that Cloudflare WARP may be the issue, or something else.

It loads infinitely long and after a few seconds, a new captcha gets instantly solved(?) and then it loads again.

Steps to Reproduce (add as many as necessary):

  1. Open a website that uses Cloudflare CAPTCHAs or protection.
  2. Enable Cloudflare WARP in the Brave browser (or disable it, doesn’t make a difference honestly).
  3. Try to load the website.

Actual Result (gifs and screenshots are welcome!):
Here is an example, of what happens if I visit a page that is protected by Cloudflare:

Expected result:
The website should load like every other website.

Reproduces how often:
almost every time I visit a page that is protected by Cloudflare. Maybe some pages from Germany are not affected, but couldn’t test that - I live in Germany.

Operating System and Brave Version(See the About Brave page in the main menu):

  • Brave Browser: 1.61.101
  • Cloudflare WARP: 2023.11.6.0
  • Windows 11 Pro

Additional Information:

I have tried the following to resolve the issue:

  • Updating Brave to the latest version
  • Disabling all protection in Brave
  • Disabling Cloudflare WARP

What I don’t see is some of the basic troubleshooting steps. Could you try the steps below, one at a time.

  • Open in Private, does it work?

  • Add a new profile (Hamburger menu image → More Tools → Add new profile) and test there without changing settings or adding extensions.

  • If you’re using a VPN or proxy, try to disable it and see if it makes a difference

If the above don’t work:

  • Test on Brave Beta or Brave Nightly.

If still having the issue:

  • Test on Chrome.
  • A private tab is working as it should.

  • A new profile works.

  • I don’t use a VPN (except Cloudflare WARP, but disabling it doesn’t changed anything)

  • All extensions are disabled on the website that I use for testing with my normal profile

  • all other browsers are also working fine

If it works as it should, this step here essentially tells us the issue.

The only differences between private window and normal are:

  1. Private window opens with no cookies

  2. Private loads without extensions by default

  3. Private clears history and cookies when session ends

So it’s either that you need to clear cookies or you need to remove/disable extensions (at least figure out which one is causing the problem).

Since you said you have disabled extensions (though it concerns me how you phrase it “on the website” rather than just saying they’re disabled through the browser), likely would move to clear cookies, making sure to select All Time for the range.

If it still keeps happening after clearing cookies, then we have to look more at your extensions and what you’re doing. Plus, sadly, sometimes have to remove extensions completely for them to stop interfering. If we get to this step and you have multiple extensions, it might be easier to add the extensions, one at a time, to your new profile and see if you can figure out which one is the culprit.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.