Closing/Reopening Brave locks 1Password extension

Description of the issue:
The 1Password extension locks whenever Brave is closed and reopened. I think it locks other times too but I haven’t been able to pin down a procedure that always locks it except to close Brave and re-open it.

How can this issue be reproduced?

  1. Install 1Password extension.
    I have version 1.22.3 installed now but I don’t think this is a new or version specific problem.
  2. Open Brave. The 1Password icon in the menu bar will show a closed lock symbol.
  3. Unlock it.
  4. Close Brave
  5. Open Brave again.
  6. The extension will be locked again.

Expected result:
The extension should stay unlocked unless the Mac is restarted. That’s what happens with Safari.

Brave Version( check About Brave):
V1.19.92

Additional Information:
I don’t see any options in the extension’s Details page to manage unlocking. I don’t know whether the extension pays any attention to 1Password app’s settings. Its Preferences → Security page does include options to lock on sleep and several other conditions. The only one I have checked is “lock on fast user switching”.

2021-03-02 Update
Problem was in the 1Password extension rather than Brave. The “classic” version (4.7.x) of the extension used to lock/unlock when the desktop app locks/unlocks but the version in the Chrome Store currently (1.23.x ) ignores the desktop app. The classic version is still available in Chrome’s Store. In order to install it:

  • Remove any versions of the extension that are currently installed
  • Enter https://chrome.google.com/webstore/detail/1password-extension-deskt/aomjjhallfgjeglblehebfpbcfeobpgk in Brave’s navigation box.
    (I don’t know why this version doesn’t show up if I simply enter “1Password” in the Store’s Search field. Found the link in the discussion at https://1password.community/discussion/comment/585279#Comment_585279.)
  • Install the extension
  • I’m not sure but you may have to Quit and restart Brave to get the extension loaded.
  • Left-click the shaded blob “Extensions” icon second from the right end of Brave’s menu bar.
  • Left-click the “Pin” icon for 1Password. (I don’t think you have to do this for the extension to autofill once you’re on a page but you do if you want to select a site in the extension and have it open the site and autofill all in one step.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.